Unverified Commit 27b9516e authored by prspkt's avatar prspkt

community/libqmi: upgrade to 1.22.2

Add libmbim-dev and --enable-mbim-qmux to support QMI-over-MBIM.
parent dcf5561e
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libqmi
pkgver=1.20.2
pkgver=1.22.2
pkgrel=0
pkgdesc="QMI modem protocol helper library"
url="https://www.freedesktop.org/wiki/Software/libqmi"
arch="all"
license="GPL-2.0"
makedepends="gtk-doc python2 glib-dev libgudev-dev linux-headers"
makedepends="gtk-doc python2 glib-dev libgudev-dev linux-headers libmbim-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
......@@ -19,6 +19,7 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static \
--enable-mbim-qmux \
--enable-more-warnings=yes
make
}
......@@ -33,4 +34,4 @@ package() {
make DESTDIR="$pkgdir" install
}
sha512sums="2d1ceda25ad995b27dc20d9b5d85ee23a841c43f33aa68b3543df10cc1da72062e648c1136a2706740659ae2cf8c17373d7c6c6f5f8d075864f47e4fb89d7b50 libqmi-1.20.2.tar.xz"
sha512sums="5785b56a60db8fb2566b6a712a18ec2ae74ce1da257473ab6b7cdea3163298ebee6c60a3158a7041aa759bd717eee4b16d9eeaa6b15d9b6e911bc8c8c44bd3d8 libqmi-1.22.2.tar.xz"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment