diff --git a/testing/watchbind/APKBUILD b/testing/watchbind/APKBUILD
index b4dc030d0b509ed669743736c63072f3ce9fda35..8b302a7bcaa3a15ae793f794a671b25cd19549bd 100644
--- a/testing/watchbind/APKBUILD
+++ b/testing/watchbind/APKBUILD
@@ -10,7 +10,8 @@ license="GPL-3.0-or-later"
 makedepends="cargo cargo-auditable"
 subpackages="$pkgname-doc"
 options="net"
-source="$pkgname-$pkgver.tar.gz::https://github.com/fritzrehde/watchbind/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/fritzrehde/watchbind/archive/v$pkgver.tar.gz
+	cargo-update.patch"
 
 prepare() {
 	default_prepare
@@ -33,4 +34,5 @@ package() {
 
 sha512sums="
 4084e854e070b2c9736e2ef10025f6703efcac8e9fb9c345f09e03a2048d0437e2d470b684f25306b66fca99cbeab40202d0560eba24aa2a69220b34369d2f46  watchbind-0.2.1.tar.gz
+88b35a6e48e90cb1a17329fd641e7bed3ffd604b25c3ae9543ec91209b90a7491f74d7069d9c504fd44dda6a07429969ebeb2d68502bcbe0997b749b99021ece  cargo-update.patch
 "
diff --git a/testing/watchbind/cargo-update.patch b/testing/watchbind/cargo-update.patch
new file mode 100644
index 0000000000000000000000000000000000000000..42a2bfa847f93630caa1411bef99b97936c07ab3
--- /dev/null
+++ b/testing/watchbind/cargo-update.patch
@@ -0,0 +1,16 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index c96c886..8c8f4f5 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -605,9 +605,9 @@ checksum = "b1a46d1a171d865aa5f83f92695765caa047a9b4cbae2cbf37dbd613a793fd4c"
+ 
+ [[package]]
+ name = "libc"
+-version = "0.2.152"
++version = "0.2.155"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "13e3bf6590cbc649f4d1a3eefc9d5d6eb746f5200ffb04e5e142700b8faa56e7"
++checksum = "97b3888a4aecf77e811145cadf6eef5901f4782c53886191b2f693f24761847c"
+ 
+ [[package]]
+ name = "libredox"