From 2761a0fc402cfbccafeca12ac65926bf30563a1d Mon Sep 17 00:00:00 2001
From: pglaum <p@pglaum.de>
Date: Tue, 21 Jul 2020 13:49:01 +0200
Subject: [PATCH] testing/py3-pytest-rerunfailures: new aport

Pytest plugin to re-run tests to eliminate flaky failures
https://pypi.org/project/pytest-rerunfailures/
---
 testing/py3-pytest-rerunfailures/APKBUILD | 29 +++++++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 testing/py3-pytest-rerunfailures/APKBUILD

diff --git a/testing/py3-pytest-rerunfailures/APKBUILD b/testing/py3-pytest-rerunfailures/APKBUILD
new file mode 100644
index 000000000000..6152522c2d8e
--- /dev/null
+++ b/testing/py3-pytest-rerunfailures/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Philipp Glaum <p@pglaum.de>
+# Maintainer: Philipp Glaum <p@pglaum.de>
+pkgname=py3-pytest-rerunfailures
+_pkgname=pytest-rerunfailures
+pkgver=9.0
+pkgrel=0
+pkgdesc="Pytest plugin to re-run tests to eliminate flaky failures"
+url="https://pypi.org/project/pytest-rerunfailures/"
+arch="noarch"
+license="MPL-2.0"
+depends="python3 py3-pytest"
+makedepends="py3-setuptools"
+checkdepends="py3-mock"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	py.test-3
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c5ac12dda4b8411627be2950baa3c910cdb9b7111d792adcfa55d053912090ab6a221de481938d8722c346d34b07fe7f629be7e853d209ea41c4d7efb1781c0c  pytest-rerunfailures-9.0.tar.gz"
-- 
GitLab