diff --git a/main/tevent/APKBUILD b/main/tevent/APKBUILD
index 44743743b70f587255741e8b8081c36c7a9abea4..2d26a985966c7fbeee7db4ececd20bb13deeb928 100644
--- a/main/tevent/APKBUILD
+++ b/main/tevent/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=tevent
-pkgver=0.11.0
-pkgrel=2
+pkgver=0.13.0
+pkgrel=0
 pkgdesc="The tevent library"
 url="https://tevent.samba.org/"
 arch="all"
@@ -10,8 +10,6 @@ makedepends="libtirpc-dev python3-dev talloc-dev cmocka-dev"
 replaces="samba"
 subpackages="$pkgname-dev py3-$pkgname:_py3"
 source="https://samba.org/ftp/tevent/tevent-$pkgver.tar.gz
-	fix-public-header.patch
-	python-3.10.patch
 	"
 
 build() {
@@ -45,7 +43,5 @@ _py3() {
 }
 
 sha512sums="
-740346b19bf290ff31b0c1b36e232021b8ad107c3ce27e0e8b1ec1a77485214b07a9b7837ba57f3650a50e4c04f530674e486b5fa4d118a1778259be63b49790  tevent-0.11.0.tar.gz
-ee4cce8591dfe31288975596d8464b7cc160580715f88e4fd19b5ae7e1a831650b072954731f015f52d76600597faee894f0174b9e92d18dca9629f9d056230c  fix-public-header.patch
-8014ee4a58c4fdb432c93d999c102b6197d429a80be8553383d74e36d6d291862a64afa081ec17d1f45ae84a61bc0580f0f6eb969462839043828207d2235196  python-3.10.patch
+7aa05c09e3c708769e31cda88b319cee3629c88c51bda559193a85d4ab32204a8b4ba11f142861dbca06b578bf54953f2aca1ad847e99995a4fc40bf08618a93  tevent-0.13.0.tar.gz
 "
diff --git a/main/tevent/fix-public-header.patch b/main/tevent/fix-public-header.patch
deleted file mode 100644
index 2b60347aba8511b016a50a1e37670ad68ce10b1b..0000000000000000000000000000000000000000
--- a/main/tevent/fix-public-header.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-tevent.h needs sys/types.h for pid_t
-
-diff -ru tevent-0.9.37.orig/tevent.h tevent-0.9.37/tevent.h
---- tevent-0.9.37.orig/tevent.h	2018-07-12 05:51:30.000000000 +0000
-+++ tevent-0.9.37/tevent.h	2018-07-19 10:13:15.360128807 +0000
-@@ -31,6 +31,7 @@
- #include <stdint.h>
- #include <talloc.h>
- #include <sys/time.h>
-+#include <sys/types.h>
- #include <stdbool.h>
- 
- struct tevent_context;
diff --git a/main/tevent/python-3.10.patch b/main/tevent/python-3.10.patch
deleted file mode 100644
index 9bba772c7ec2915d2c5a802ae1363319756bec42..0000000000000000000000000000000000000000
--- a/main/tevent/python-3.10.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 02b187303369d3ce0c19dfb72ffa78f86a3911f0 Mon Sep 17 00:00:00 2001
-From: Joseph Sutton <josephsutton@catalyst.net.nz>
-Date: Wed, 28 Apr 2021 16:48:55 +1200
-Subject: [PATCH] Fix Python docstrings
-
-Signed-off-by: Joseph Sutton <josephsutton@catalyst.net.nz>
-Reviewed-by: Andrew Bartlett <abartlet@samba.org>
-Reviewed-by: Jeremy Allison <jra@samba.org>
-
-Autobuild-User(master): Jeremy Allison <jra@samba.org>
-Autobuild-Date(master): Sat Sep  4 00:55:32 UTC 2021 on sn-devel-184
----
- lib/ldb/pyldb.c                  | 2 +-
- lib/tdb/pytdb.c                  | 2 +-
- lib/tevent/pytevent.c            | 2 +-
- source4/librpc/ndr/py_security.c | 2 +-
- 4 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/lib/tevent/pytevent.c b/lib/tevent/pytevent.c
-index 93375f71868..62dfe2419ff 100644
---- a/pytevent.c
-+++ b/pytevent.c
-@@ -573,7 +573,7 @@ static PyMethodDef py_tevent_context_methods[] = {
- 	{ "add_timer", (PyCFunction)py_tevent_context_add_timer,
- 		METH_VARARGS, "S.add_timer(next_event, handler) -> timer" },
- 	{ "add_timer_offset", (PyCFunction)py_tevent_context_add_timer_offset,
--		METH_VARARGS, "S.add_timer(offset_seconds, handler) -> timer" },
-+		METH_VARARGS, "S.add_timer_offset(offset_seconds, handler) -> timer" },
- 	{ "add_fd", (PyCFunction)py_tevent_context_add_fd, 
- 		METH_VARARGS, "S.add_fd(fd, flags, handler) -> fd" },
- 	{0},
--- 
-GitLab
-