diff --git a/community/moc/APKBUILD b/community/moc/APKBUILD
index 56b90f131b60d7580705d40177fa4036d5f6ee28..570bbc8f34871061b25de5b3ec118c4d059de81a 100644
--- a/community/moc/APKBUILD
+++ b/community/moc/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
 pkgname=moc
 pkgver=2.5.2
-pkgrel=1
+pkgrel=2
 pkgdesc="MOC is a console audio player"
 url="http://moc.daper.net/"
 arch="all"
@@ -14,6 +14,7 @@ subpackages="$pkgname-doc"
 source="
 	http://ftp.daper.net/pub/soft/moc/stable/moc-$pkgver.tar.bz2
 	ffmpeg4.patch
+	fix-https.patch
 "
 
 prepare() {
@@ -58,4 +59,5 @@ package() {
 sha512sums="
 992d06809fb52e58dcee63704bde05795b99edbac46edd8381f314c564490013b18e1853926f419c2c3c7f1bb68ff35e97048de03ace3232b800cf4b3b7dbe0f  moc-2.5.2.tar.bz2
 a2af41467573b6f674be4007fda5990035513da6733030b882874dd44562b75c88c63e60c1d84a7b6522191bb4dbc38fb4e7d8462ba4add7425643dcbbf6d315  ffmpeg4.patch
+e8686c2c1050f3c41147f90488f4d264eb50f5b5d9c5fc03172bf4fd70a3220ebac147e03ab773d330c55fc4e0a20538c6724ca094003716fa448202af0782d1  fix-https.patch
 "
diff --git a/community/moc/fix-https.patch b/community/moc/fix-https.patch
new file mode 100644
index 0000000000000000000000000000000000000000..c2ed02cd10b7c35594ee447567bdb5cd4f55a455
--- /dev/null
+++ b/community/moc/fix-https.patch
@@ -0,0 +1,11 @@
+Patch-Source: https://github.com/archlinux/svntogit-packages/blob/f29848ed88885b6e12188683d5f9299246271543/trunk/moc-https.patch
+--- a/files.c
++++ b/files.c
+@@ -93,6 +93,7 @@
+ inline int is_url (const char *str)
+ {
+ 	return !strncasecmp (str, "http://", sizeof ("http://") - 1)
++		|| !strncasecmp (str, "https://", sizeof ("https://") - 1)
+ 		|| !strncasecmp (str, "ftp://", sizeof ("ftp://") - 1);
+ }
+