diff --git a/community/zlib-ng/APKBUILD b/community/zlib-ng/APKBUILD
index 5b75248fdb58147ab35c55e1ae9f853231a1bb98..42d6eddfa24a76c9548dd2e8fe985eb72e176f98 100644
--- a/community/zlib-ng/APKBUILD
+++ b/community/zlib-ng/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=zlib-ng
 pkgver=2.2.4
-pkgrel=0
+pkgrel=1
 pkgdesc="zlib replacement with optimizations for next generation systems"
 url="https://github.com/zlib-ng/zlib-ng"
 arch="all"
@@ -21,15 +21,12 @@ build() {
 	if [ "$CBUILD" != "$CHOST" ]; then
 		crossopts="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
 	fi
-	# WITH_UNALIGNED - unaligned access invokes undefined behaviour,
-	#   see https://github.com/gentoo/gentoo/pull/17167 for more info.
 	cmake -B build -G Ninja \
 		-DCMAKE_BUILD_TYPE=Release \
 		-DCMAKE_INSTALL_PREFIX=/usr \
 		-DCMAKE_VERBOSE_MAKEFILE=ON \
 		-DWITH_DFLTCC_DEFLATE=ON \
 		-DWITH_DFLTCC_INFLATE=ON \
-		-DWITH_UNALIGNED=OFF \
 		-DZLIB_ENABLE_TESTS="$(want_check && echo ON || echo OFF)" \
 		-DZLIBNG_ENABLE_TESTS="$(want_check && echo ON || echo OFF)" \
 		-DWITH_GTEST=OFF \