diff --git a/community/py3-daemon/APKBUILD b/community/py3-daemon/APKBUILD
index 9a3f171e8971ff55a6429bcc406f56288090c91b..1dfa7b4b0643e673403a6fdc1eec622c9afcdd1f 100644
--- a/community/py3-daemon/APKBUILD
+++ b/community/py3-daemon/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Noel Kuntze <noel.kuntze@thermi.consulting>
 # Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
 pkgname=py3-daemon
-pkgver=3.0.1
+pkgver=3.1.1
 pkgrel=0
 pkgdesc="Library to implement a well-behaved Unix daemon process"
 url="https://pagure.io/python-daemon"
@@ -10,15 +10,13 @@ arch="noarch"
 license="Apache-2.0 AND GPL-3.0-or-later"
 depends="py3-setuptools py3-lockfile"
 makedepends="
+	py3-changelog-chug
 	py3-docutils
 	py3-gpep517
 	py3-wheel"
 subpackages="$pkgname-pyc"
-source="
-	https://pypi.io/packages/source/p/python-daemon/python-daemon-$pkgver.tar.gz
-	remove-docutils-depend.patch
-"
-builddir="$srcdir/python-daemon-$pkgver"
+source="https://files.pythonhosted.org/packages/source/p/python_daemon/python_daemon-$pkgver.tar.gz"
+builddir="$srcdir/python_daemon-$pkgver"
 
 prepare() {
 	default_prepare
@@ -40,6 +38,5 @@ package() {
 }
 
 sha512sums="
-ea35ec3e930e533ef08a492aa36492a958c9258857cdc75ab2ddb6688a7d8990282cfa0f63ee5cb6b7036b9cb71be03631d5d0d58788a08052425a441bce4e9a  python-daemon-3.0.1.tar.gz
-20bc4bce7fba9754d1c9bca298f9b4ff7fe90ecf51769df2020912f370650a5997f91c99c6be2ecffed10a6b359a29b1f64b0c391772451eb3c04769df381015  remove-docutils-depend.patch
+faf074e8ef07b5cda32cbdd66f613d2830569d6a0316b8048e0173b65c45b5472a42a90edacecb811c4cd7daf1d239f898f8a939c4dfb807ef88455f2dc27a9b  python_daemon-3.1.1.tar.gz
 "
diff --git a/community/py3-daemon/remove-docutils-depend.patch b/community/py3-daemon/remove-docutils-depend.patch
deleted file mode 100644
index 2bbc3bee30aa7198217ddf8c3073b9f5e491ac16..0000000000000000000000000000000000000000
--- a/community/py3-daemon/remove-docutils-depend.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/setup.py.orig b/setup.py
-index 24f0e7cb98a..d712294c20b 100644
---- a/setup.py.orig
-+++ b/setup.py
-@@ -96,11 +96,6 @@ setup_kwargs = dict(
-             ],
-         )
- 
--# Docutils is only required for building, but Setuptools can't distinguish
--# dependencies properly.
--# See <URL:https://github.com/pypa/setuptools/issues/457>.
--setup_kwargs['install_requires'].append("docutils")
--
- 
- if __name__ == '__main__':
-     setup(**setup_kwargs)