From 2511d0a5a709c80d70a5b50747ceaacc935e11c5 Mon Sep 17 00:00:00 2001
From: Keith Maxwell <keith.maxwell@gmail.com>
Date: Tue, 5 May 2020 08:12:58 +0100
Subject: [PATCH] main/subunit: fix shebang lines
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Before this change:

    $ dabuild sh
    $ sudo apk add subunit >/dev/null && subunit-stats --help
    env: can't execute 'python': No such file or directory

After this change:

    $ dabuild sh
    $ sudo apk add subunit >/dev/null && subunit-stats --help
    Usage: subunit-stats [options]
    ✂
---
 main/subunit/APKBUILD | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/main/subunit/APKBUILD b/main/subunit/APKBUILD
index b4b3e701f340..dbd41c75285e 100644
--- a/main/subunit/APKBUILD
+++ b/main/subunit/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=subunit
 pkgver=1.3.0
-pkgrel=0
+pkgrel=1
 pkgdesc="A streaming protocol for test results"
 options="!check" # Dependencies for checking stuff are in testing/
 url="https://launchpad.net/subunit"
@@ -40,6 +40,7 @@ package() {
 	make DESTDIR="$pkgdir" install
 	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
 	rm -f "$pkgdir"/usr/lib/*.a
+	sed -i '1s|/usr/bin/env python$|/usr/bin/python3|' "$pkgdir"/usr/bin/*
 }
 
 sha512sums="7b37890546345cc481779f4bf1dc7eeca4fbda0efff1b7d7a6ca7ec574fe72e9801b7b70b8efcb0d78bb6a0a181fcdb6e49a2ff280d73f0d3dfcd1df219b2765  subunit-1.3.0.tar.gz"
-- 
GitLab