diff --git a/community/webkit2gtk/APKBUILD b/community/webkit2gtk/APKBUILD
index d4fcc97d640c05fab1dd62741258f92d352b9f79..cab855d7d83101c6c71e0de1bee25e8b9258a63f 100644
--- a/community/webkit2gtk/APKBUILD
+++ b/community/webkit2gtk/APKBUILD
@@ -194,7 +194,7 @@ build() {
 		# disable _FORTIFY_SOURCE to work around:
 		# cc1plus: out of memory allocating 65536 bytes after a total of 3131101184 bytes
 		x86) CXXFLAGS="$CXXFLAGS -U_FORTIFY_SOURCE";;
-		armhf|armv7|ppc64le|s390x) _archopt="-DENABLE_JIT=OFF";;
+		armhf|ppc64le|s390x) _archopt="-DENABLE_JIT=OFF";;
 	esac
 
 	# reduce memory usage on 32 bit