From 223dcac4f6340cde9c1c3ceeb0f4d9c759d24163 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Sat, 23 Jul 2022 06:28:43 +0000
Subject: [PATCH] community/qt6-qtbase: reduce dbg size

---
 community/qt6-qtbase/APKBUILD | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/community/qt6-qtbase/APKBUILD b/community/qt6-qtbase/APKBUILD
index 2a327ef154c5..527d22d98a88 100644
--- a/community/qt6-qtbase/APKBUILD
+++ b/community/qt6-qtbase/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=qt6-qtbase
 pkgver=6.3.0
-pkgrel=1
+pkgrel=2
 pkgdesc="A cross-platform application and UI framework"
 url="https://qt.io/"
 arch="all"
@@ -74,8 +74,10 @@ esac
 [ "$CARCH" = "riscv64" ] && options="$options textrels"
 
 build() {
+	# significantly reduce debug symbol size
+	CFLAGS="$CFLAGS -g1" CXXFLAGS="$CXXFLAGS -g1" \
 	cmake -B build -G Ninja \
-		-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+		-DCMAKE_BUILD_TYPE=Release \
 		-DCMAKE_INSTALL_PREFIX=/usr \
 		-DINSTALL_BINDIR=lib/qt6/bin \
 		-DINSTALL_PUBLICBINDIR=usr/bin \
-- 
GitLab