From 21342521ad6602326dcba28cc45c50311e17f11c Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
Date: Fri, 1 Nov 2024 20:50:56 +1000
Subject: [PATCH] testing/py3-jupyterlab: new aport

Signed-off-by: Alistair Francis <alistair@alistair23.me>
---
 testing/py3-jupyterlab/APKBUILD | 64 +++++++++++++++++++++++++++++++++
 1 file changed, 64 insertions(+)
 create mode 100644 testing/py3-jupyterlab/APKBUILD

diff --git a/testing/py3-jupyterlab/APKBUILD b/testing/py3-jupyterlab/APKBUILD
new file mode 100644
index 000000000000..4125d5750a6e
--- /dev/null
+++ b/testing/py3-jupyterlab/APKBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Alistair Francis <alistair@alistair23.me>
+pkgname=py3-jupyterlab
+_pyname=jupyterlab
+pkgver=4.3.0
+pkgrel=0
+pkgdesc="An extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture."
+url="https://jupyterlab.readthedocs.io/en/latest/"
+# loongarch64, ppc64le, riscv64, s390x fail to fetch npm dependencies
+# 32-bit architectures have the same issue
+arch="noarch !armhf !armv7 !x86 !loongarch64 !ppc64le !riscv64 !s390x"
+license="BSD-3-Clause"
+depends="
+	jupyter-notebook-shim
+	python3
+	py3-async-lru
+	py3-httpx
+	py3-ipykernel
+	"
+makedepends="
+	jupyter-notebook-shim
+	jupyter-server
+	nodejs
+	npm
+	py3-async-lru
+	py3-babel
+	py3-gpep517
+	py3-hatch-jupyter-builder
+	py3-hatchling
+	py3-httpx
+	py3-installer
+	py3-ipykernel
+	py3-json5
+	py3-jupyterlab_server
+	py3-poetry-core
+	py3-pytest-jupyter
+	py3-requests
+	py3-setuptools
+	py3-wheel
+	yarn
+	"
+checkdepends="py3-pytest py3-setuptools py3-pexpect"
+source="py3-jupyterlab-$pkgver.tar.gz::https://github.com/jupyterlab/jupyterlab/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pyname-$pkgver
+
+build() {
+	gpep517 build-wheel \
+		--wheel-dir .dist \
+		--output-fd 3 3>&1 1>&2
+}
+
+check() {
+	python3 -m venv --clear --without-pip --system-site-packages .testenv
+	.testenv/bin/python3 -m installer .dist/*.whl
+	.testenv/bin/python3 -m pytest -k 'not test_python_render_simple_indent_guides and not test_python_render_line_range_indent_guides'
+}
+
+
+package() {
+	python3 -m installer -d "$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+8e4fe06f0b83e87bb83f4ab6bdc2eed42ca88a78435a85ec8bd25e86fa3f5af11f45507f08b81c1864969efff48e9969d96067ef71093b160cdedc2cd3ffe17b  py3-jupyterlab-4.3.0.tar.gz
+"
-- 
GitLab