diff --git a/main/icon-naming-utils/APKBUILD b/main/icon-naming-utils/APKBUILD
index fe66d8cab01a94ee11b46f66b6b7467f504cfe40..0495770bbe0ce3cb4b5520fdd589549994886a6f 100644
--- a/main/icon-naming-utils/APKBUILD
+++ b/main/icon-naming-utils/APKBUILD
@@ -1,12 +1,12 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=icon-naming-utils
 pkgver=0.8.90
-pkgrel=3
+pkgrel=4
 pkgdesc="Maps the new names of icons for Tango to the legacy names used by the GNOME and KDE desktops."
 url="http://tango.freedesktop.org/"
 arch="noarch"
 options="!check"  # No test suite.
-license="GPL-2.0"
+license="GPL-2.0-or-later"
 depends="perl-xml-simple"
 source="http://tango.freedesktop.org/releases/icon-naming-utils-$pkgver.tar.bz2"
 
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index a2203fe80000ad469bc3f246a50c4c5e89202ea0..7d51943d765ed9a4b2355f37606d5726b294c6a3 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -3,11 +3,11 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=icu
 pkgver=72.1
-pkgrel=1
+pkgrel=2
 pkgdesc="International Components for Unicode library"
 url="https://icu.unicode.org/"
 arch="all"
-license="MIT ICU Unicode-TOU"
+license="ICU"
 depends_dev="$pkgname=$pkgver-r$pkgrel"
 makedepends="python3 py3-yaml"
 checkdepends="diffutils"
diff --git a/main/imake/APKBUILD b/main/imake/APKBUILD
index a65ddd6285e1f9a1def82f8190c1b009a6a40ffd..8df81f29ab9a7541567ad8fbb5178af7913eb216 100644
--- a/main/imake/APKBUILD
+++ b/main/imake/APKBUILD
@@ -1,11 +1,11 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=imake
 pkgver=1.0.9
-pkgrel=0
+pkgrel=1
 pkgdesc="X Windows make utility"
 url="https://www.x.org"
 arch="all"
-license="MIT-enna"
+license="custom"
 options="!check"  # No test suite.
 makedepends="util-macros xorgproto"
 subpackages="$pkgname-doc"
@@ -18,6 +18,7 @@ build() {
 
 package() {
 	make DESTDIR="$pkgdir" install
+	install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
 }
 
 sha512sums="
diff --git a/main/indent/APKBUILD b/main/indent/APKBUILD
index c495000873e97b1ab46cc8bd2a18a6a8f62bf77e..c4601aa012b2be8f5390c2d392df22b276fa8654 100644
--- a/main/indent/APKBUILD
+++ b/main/indent/APKBUILD
@@ -2,11 +2,11 @@
 # Maintainer:
 pkgname=indent
 pkgver=2.2.12
-pkgrel=2
+pkgrel=3
 pkgdesc="An indenting utility"
 url="https://www.gnu.org/software/indent/"
 arch="all"
-license="GPL-3.0-or-later BSD"
+license="GPL-3.0-or-later"
 makedepends="gettext-dev"
 options="!check" #texinfo
 subpackages="$pkgname-doc $pkgname-lang"
diff --git a/main/installkernel/APKBUILD b/main/installkernel/APKBUILD
index 6db7dec048b826bc043a76e5ac382d5a12dfcb95..68d6fb8743d1ed63829aa7f81bb3584572dc67de 100644
--- a/main/installkernel/APKBUILD
+++ b/main/installkernel/APKBUILD
@@ -1,11 +1,11 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=installkernel
 pkgver=3.5
-pkgrel=2
+pkgrel=3
 pkgdesc="Alpine Linux Kernel install script"
 url="https://git.alpinelinux.org/cgit/aports/tree/main/installkernel"
 arch="noarch"
-license="GPL-2.0"
+license="GPL-2.0-only"
 options="!check" # no test suite
 source="installkernel"
 
diff --git a/main/intltool/APKBUILD b/main/intltool/APKBUILD
index 3bbe96459c28fdd95a3958c102dba8eda0a73783..c9d6d6bf68b972b58341c9a3647105eacb5d0b88 100644
--- a/main/intltool/APKBUILD
+++ b/main/intltool/APKBUILD
@@ -1,11 +1,11 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=intltool
 pkgver=0.51.0
-pkgrel=5
+pkgrel=6
 pkgdesc="The internationalization tool collection"
 url="http://freedesktop.org/wiki/Software/intltool"
 arch="noarch"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
 depends="perl perl-xml-parser gettext file"
 subpackages="$pkgname-doc"
 source="https://edge.launchpad.net/intltool/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz
diff --git a/main/iperf3/APKBUILD b/main/iperf3/APKBUILD
index 34616660d3cbf935e708099676255308d01d71fb..9bfd9fdf2646fffa6f4aecfd32b8e95388dc5adb 100644
--- a/main/iperf3/APKBUILD
+++ b/main/iperf3/APKBUILD
@@ -3,11 +3,11 @@
 pkgname=iperf3
 _pkgname=iperf
 pkgver=3.12
-pkgrel=0
+pkgrel=1
 pkgdesc="A tool to measure IP bandwidth using UDP or TCP"
 url="https://github.com/esnet/iperf"
 arch="all"
-license="BSD-3-Clause"
+license="BSD-3-Clause-LBNL"
 subpackages="$pkgname-dev $pkgname-doc $pkgname-openrc"
 source="$pkgname-$pkgver.tar.gz::https://github.com/esnet/$_pkgname/archive/$pkgver.tar.gz
 	$pkgname.initd
diff --git a/main/iproute2-qos/APKBUILD b/main/iproute2-qos/APKBUILD
index 3ff43ed507838fd4589ddb79b0b629950b224c02..a25f94080a2f2581d8a809e6ff6cb6ae1df8ecd4 100644
--- a/main/iproute2-qos/APKBUILD
+++ b/main/iproute2-qos/APKBUILD
@@ -2,11 +2,11 @@
 # Maintainer: Iilluzion <iilluzion@gmail.com>
 pkgname=iproute2-qos
 pkgver=0.5
-pkgrel=3
+pkgrel=4
 pkgdesc="Scripts to set up quality of service with iproute2"
 url="https://git.alpinelinux.org/cgit/aports"
 arch="noarch"
-license="GPL-2.0"
+license="GPL-2.0-only"
 depends="iproute2"
 source="qos.initd qos.eth0.sample qos.ifb0.sample setup-qos"
 
diff --git a/main/iucode-tool/APKBUILD b/main/iucode-tool/APKBUILD
index 51137f09218d4423ea480d4d1ded716b56d2db6b..44b61232d920cadbea419b52f63150a8cfd352a2 100644
--- a/main/iucode-tool/APKBUILD
+++ b/main/iucode-tool/APKBUILD
@@ -1,11 +1,11 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=iucode-tool
 pkgver=2.3.1
-pkgrel=1
+pkgrel=2
 pkgdesc="manipulate microcode update collections for Intel i686 and X86-64"
 url="https://gitlab.com/iucode-tool/iucode-tool"
 arch="x86 x86_64"
-license="GPLv2+"
+license="GPL-2.0-or-later"
 makedepends="autoconf automake libtool argp-standalone"
 subpackages="$pkgname-doc"
 source="https://gitlab.com/iucode-tool/iucode-tool/-/archive/v$pkgver/iucode-tool-v$pkgver.tar.gz"
diff --git a/main/ivykis/APKBUILD b/main/ivykis/APKBUILD
index 77894bdbd02e8e54877b35ebef11b16c3416546f..6be83d2fc5538ff15173600cd165a18b2960f55e 100644
--- a/main/ivykis/APKBUILD
+++ b/main/ivykis/APKBUILD
@@ -2,11 +2,11 @@
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=ivykis
 pkgver=0.42.4
-pkgrel=2
+pkgrel=3
 pkgdesc="Library for asynchronous I/O readiness notification"
 url="https://libivykis.sourceforge.net/"
 arch="all"
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
 makedepends="automake autoconf libtool"
 subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
 source="https://downloads.sourceforge.net/project/libivykis/$pkgver/ivykis-$pkgver.tar.gz"