From 1c2274e052f1e3f1736ea95ca5cc4f5b1f31aef5 Mon Sep 17 00:00:00 2001
From: ptrcnull <git@ptrcnull.me>
Date: Tue, 9 Aug 2022 10:22:54 +0200
Subject: [PATCH] community/py3-k5test: add basic import test

---
 community/py3-k5test/APKBUILD | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/community/py3-k5test/APKBUILD b/community/py3-k5test/APKBUILD
index 123aef4086d6..608bdc8e2f66 100644
--- a/community/py3-k5test/APKBUILD
+++ b/community/py3-k5test/APKBUILD
@@ -10,7 +10,6 @@ arch="noarch"
 license="MIT"
 depends="python3 krb5-dev krb5 krb5-server"
 makedepends="py3-setuptools"
-options="!check" # Package doesn't have tests
 source="https://files.pythonhosted.org/packages/source/k/$_pkgname/$_pkgname-$pkgver.tar.gz"
 builddir="$srcdir"/$_pkgname-$pkgver
 
@@ -18,6 +17,11 @@ build() {
 	python3 setup.py build
 }
 
+check() {
+	# no upstream tests
+	PYTHONPATH=build/lib python3 -c "import k5test"
+}
+
 package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
-- 
GitLab