From 1b2c2ef4824e8c3478f0a2de499f0d8cdb24d7a0 Mon Sep 17 00:00:00 2001
From: J0WI <J0WI@users.noreply.github.com>
Date: Tue, 13 Jul 2021 15:46:47 +0200
Subject: [PATCH] main/iftop: modernize

---
 main/iftop/APKBUILD | 33 +++++++++++++++++----------------
 1 file changed, 17 insertions(+), 16 deletions(-)

diff --git a/main/iftop/APKBUILD b/main/iftop/APKBUILD
index fb7813dc9856..51dcceba1624 100644
--- a/main/iftop/APKBUILD
+++ b/main/iftop/APKBUILD
@@ -1,36 +1,37 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=iftop
 pkgver=0.17
-pkgrel=7
+pkgrel=8
 pkgdesc="A tool to display bandwidth usage on an interface"
-url="http://www.ex-parrot.com/~pdw/iftop/"
+url="https://www.ex-parrot.com/~pdw/iftop/"
 arch="all"
-license="GPL-2.0"
-depends=""
+license="GPL-2.0-or-later"
 makedepends="libpcap-dev>=1 ncurses-dev"
+options="!check" # no tests
 subpackages="$pkgname-doc"
-source="http://www.ex-parrot.com/~pdw/$pkgname/download/$pkgname-$pkgver.tar.gz"
+source="https://www.ex-parrot.com/~pdw/iftop/download/iftop-$pkgver.tar.gz"
 
-_builddir="$srcdir"/iftop-$pkgver
 prepare() {
-	cd "$_builddir"
-	update_config_sub || return 1
+	cd "$builddir"
+	default_prepare
+	update_config_sub
 }
 
 build() {
-	cd "$_builddir"
+	cd "$builddir"
 	./configure \
 		--build=$CBUILD \
 		--host=$CHOST \
 		--prefix=/usr \
-		--mandir=/usr/share/man \
-		|| return 1
-	make || return 1
+		--mandir=/usr/share/man
+	make
 }
 
-package()  {
-	cd "$_builddir"
-	make DESTDIR="$pkgdir" install || return 1
+package() {
+	cd "$builddir"
+	make DESTDIR="$pkgdir" install
 }
 
-sha512sums="41e3bc5feac5927f67356f491fcab7a28f7a32102cc33c67d81c1dc755273c42e32b540b14b6254a540f1b6c1b1ad6c50e3095c3b5282db2ea12dd0049ce2ebd  iftop-0.17.tar.gz"
+sha512sums="
+41e3bc5feac5927f67356f491fcab7a28f7a32102cc33c67d81c1dc755273c42e32b540b14b6254a540f1b6c1b1ad6c50e3095c3b5282db2ea12dd0049ce2ebd  iftop-0.17.tar.gz
+"
-- 
GitLab