Commit 1a666fee authored by Natanael Copa's avatar Natanael Copa
Browse files

main/libvirt: only build xen support on x86_64

parent 512ddae7
......@@ -2,7 +2,7 @@
pkgname=libvirt
pkgver=1.1.1
_ver="${pkgver/_rc/-rc}"
pkgrel=0
pkgrel=1
pkgdesc="A virtualization API for several hypervisor and container systems"
url="http://libvirt.org/"
arch="all"
......@@ -28,7 +28,7 @@ source="http://libvirt.org/sources/$pkgname-$pkgver.tar.gz
uclibc-physmem.patch
"
if [ "$ALPINE_LIBC" != "eglibc" ]; then
if [ "$CARCH" = "x86_64" ]; then
subpackages="$subpackages $pkgname-xen"
makedepends="$makedepends xen-dev"
fi
......@@ -59,6 +59,10 @@ prepare() {
build() {
cd "$_builddir"
export LDFLAGS="$LDFLAGS -lm"
local _xen_opt=
if [ "$CARCH" = x86_64 ]; then
_xen_opt="--with-libxl"
fi
./configure \
--build=$CBUILD \
--host=$CHOST \
......@@ -67,7 +71,7 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--libexec=/usr/lib/"$pkgname" \
--with-libxl \
$_xen_opt \
--with-polkit \
|| return 1
make || return 1
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment