From 19cf36f74173f069986c421aebab851cfc580776 Mon Sep 17 00:00:00 2001
From: Duncan Bellamy <dunk@denkimushi.com>
Date: Sat, 7 Mar 2020 11:10:24 +0000
Subject: [PATCH] testing/dovecot-fts-xapian: new aport

add dovecot plugin for fts-xapian
---
 testing/dovecot-fts-xapian/APKBUILD | 36 +++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 testing/dovecot-fts-xapian/APKBUILD

diff --git a/testing/dovecot-fts-xapian/APKBUILD b/testing/dovecot-fts-xapian/APKBUILD
new file mode 100644
index 000000000000..83e41babc653
--- /dev/null
+++ b/testing/dovecot-fts-xapian/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname="dovecot-fts-xapian"
+pkgver="1.2.10"
+pkgrel=0
+pkgdesc="Dovecot xapian fts plugin"
+url="https://github.com/grosjo/fts-xapian"
+arch="all"
+license="LGPL-2.1-or-later"
+depends="dovecot xapian-core"
+makedepends="automake autoconf libtool dovecot-dev xapian-core-dev icu-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/grosjo/fts-xapian/archive/$pkgver.tar.gz"
+builddir="$srcdir/"fts-xapian-$pkgver
+
+prepare() {
+	default_prepare
+	libtoolize
+	autoreconf -vi
+}
+
+build() {
+	PANDOC=false ./configure \
+		--enable-static=no \
+		--with-dovecot=/usr/lib/dovecot
+	make
+}
+
+check() {
+	make check
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="29aedcb66e2abc941d4e916487f6ce01824e76b5ed688fb1f4423cfcbcc4386a4a01be23ebb3c6dc9d8d10f1a1e0e0ea907234fe64b5e8715957e98849d82fbc  dovecot-fts-xapian-1.2.10.tar.gz"
-- 
GitLab