diff --git a/community/process-cpp/0001-Musl-libc-fixes.patch b/community/process-cpp/0001-Musl-libc-fixes.patch
deleted file mode 100644
index 17eb60c773aa549b914ed15ce6d638a21b0bb582..0000000000000000000000000000000000000000
--- a/community/process-cpp/0001-Musl-libc-fixes.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 9e25c80e0e45c21dedc785019be95c0bbff4174d Mon Sep 17 00:00:00 2001
-From: Luca Weiss <luca@z3ntu.xyz>
-Date: Sun, 30 Dec 2018 18:01:32 +0100
-Subject: [PATCH] Musl libc fixes
-
----
- include/core/posix/standard_stream.h | 5 +++++
- src/CMakeLists.txt                   | 1 +
- src/core/posix/signal.cpp            | 2 +-
- 3 files changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/include/core/posix/standard_stream.h b/include/core/posix/standard_stream.h
-index f50a9b7..1927fa8 100644
---- a/include/core/posix/standard_stream.h
-+++ b/include/core/posix/standard_stream.h
-@@ -23,6 +23,11 @@
- 
- #include <cstdint>
- 
-+// Musl uses "#define stdin (stdin)", so the enum declaration fails with a syntax error
-+#undef stdin
-+#undef stdout
-+#undef stderr
-+
- namespace core
- {
- namespace posix
-diff --git a/src/core/posix/signal.cpp b/src/core/posix/signal.cpp
-index 9c80f21..ce8bbc1 100644
---- a/src/core/posix/signal.cpp
-+++ b/src/core/posix/signal.cpp
-@@ -151,7 +151,7 @@ public:
-             {
-                 auto result = ::read(scope.signal_fd, signal_info, sizeof(signal_info));
- 
--                for (uint i = 0; i < result / sizeof(signalfd_siginfo); i++)
-+                for (unsigned int i = 0; i < result / sizeof(signalfd_siginfo); i++)
-                 {
-                     if (has(static_cast<core::posix::Signal>(signal_info[i].ssi_signo)))
-                     {
--- 
-2.20.1
-
diff --git a/community/process-cpp/APKBUILD b/community/process-cpp/APKBUILD
index e3026ea20856e2167f6b6bb31b09e5e91ef34056..c8d13ace94ca2e0109e0c6c402520bf54f27943c 100644
--- a/community/process-cpp/APKBUILD
+++ b/community/process-cpp/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Luca Weiss <luca@lucaweiss.eu>
 pkgname=process-cpp
-pkgver=3.0.1
-pkgrel=10
+pkgver=3.0.2
+pkgrel=0
 pkgdesc="A simple convenience library for handling processes in C++11"
 url="https://gitlab.com/ubports/core/lib-cpp/process-cpp"
 arch="all"
@@ -10,8 +10,6 @@ depends_dev="properties-cpp-dev"
 makedepends="$depends_dev cmake cmake-extras boost-dev gtest-dev samurai"
 subpackages="$pkgname-dev"
 source="https://gitlab.com/ubports/core/lib-cpp/process-cpp/-/archive/$pkgver/process-cpp-$pkgver.tar.gz
-	0001-Musl-libc-fixes.patch
-	cxx17.patch
 	no-execinfo.patch
 	gcc12.patch
 	"
@@ -42,9 +40,7 @@ package() {
 }
 
 sha512sums="
-4a96d57ea211a264f088c3bebd42a8a5603ed6652d7731ff9b05190c2c71b4e4c9e65164475530fbe5cf6a77f6441cf92b00680ea61b9274a91921bb76c11e88  process-cpp-3.0.1.tar.gz
-e9ce9aba66437fe1aea61cf06bca837194b1709acb3105fb452714f4e883158369bf501dd6658e8fa75779e390896b61b6824f2ae4512343519eca524e049e4b  0001-Musl-libc-fixes.patch
-752416364e0546151e0fbc343cb38bde2654164211fc9915a3bfe549447d3dcda5be8b02305ca82b8bc6f94a971c15aa66b10383a28f342cf86fe1985762cb3c  cxx17.patch
-28fae27ccf65e34228aa44986143e0312e7a7a84c587018df4037ce83dae0c32accca2df74b34d86d038dd51490f4a4e75081e8a9254ebda1390ff73d4889d1c  no-execinfo.patch
+62effb8c8be3db4443740be08ed1edbb497b5370c44d432638d68fe2d4bf24f552baf254503f44ab3433c4d72626b3c3dc6f5ecd2d1daf1941543365f81ef6ea  process-cpp-3.0.2.tar.gz
+5f3d0fd01aac53a1c93acc7be9c53c012bfac1f7d1b6f600d5b3f8a4159deec89f3b2eee8707a0cd886d88fc9674bfa9adc291c33754f5dea515164ffa26d8c6  no-execinfo.patch
 15f47d9e1c6333f7861e535804f9bcc530bba47e7717a635a5720da39cce0f198867b577e95f42b9f1014e82e43deceabfe137e80eb9c8984945b0c4646c4362  gcc12.patch
 "
diff --git a/community/process-cpp/cxx17.patch b/community/process-cpp/cxx17.patch
deleted file mode 100644
index ad988d934c434e155cf1ec58133381227b8ad744..0000000000000000000000000000000000000000
--- a/community/process-cpp/cxx17.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 0cf8ff5..adfa7e1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -29,7 +29,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
- include(GNUInstallDirs)
- 
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pedantic -Wextra -fvisibility=hidden")
--set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -fno-strict-aliasing -fvisibility=hidden -fvisibility-inlines-hidden -pedantic -Wextra")
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17 -Wall -fno-strict-aliasing -fvisibility=hidden -fvisibility-inlines-hidden -pedantic -Wextra")
- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined")
- 
- option(PROCESS_CPP_WERROR "Treat warnings as errors" ON)
diff --git a/community/process-cpp/no-execinfo.patch b/community/process-cpp/no-execinfo.patch
index a7edfbf7bd9eaef8545257f205874a4ae0cff923..74a1f9f091ea4994e4117c9e55e49867e60f04b8 100644
--- a/community/process-cpp/no-execinfo.patch
+++ b/community/process-cpp/no-execinfo.patch
@@ -1,5 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5dee0b3..705424f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,7 +21,6 @@ project(process-cpp)
+ find_package(Boost COMPONENTS iostreams system REQUIRED)
+ find_package(PkgConfig REQUIRED)
+ find_package(Threads REQUIRED)
+-find_package(Backtrace)
+ 
+ pkg_check_modules(PROPERTIES_CPP properties-cpp)
+ 
 diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 063ece1..84cf036 100644
+index 338815a..84cf036 100644
 --- a/src/CMakeLists.txt
 +++ b/src/CMakeLists.txt
 @@ -17,9 +17,6 @@
@@ -12,8 +24,16 @@ index 063ece1..84cf036 100644
    core/posix/child_process.cpp
    core/posix/exec.cpp
    core/posix/fork.cpp
+@@ -45,7 +42,6 @@ target_link_libraries(
+ 
+   ${Boost_LIBRARIES}
+   ${CMAKE_THREAD_LIBS_INIT}
+-  ${Backtrace_LIBRARIES}
+ )
+ 
+ # We compile with all symbols visible by default. For the shipping library, we strip
 diff --git a/src/core/posix/fork.cpp b/src/core/posix/fork.cpp
-index 1c9c1f3..a638da6 100644
+index e05cc53..a3f6d7c 100644
 --- a/src/core/posix/fork.cpp
 +++ b/src/core/posix/fork.cpp
 @@ -19,8 +19,6 @@
@@ -54,7 +74,7 @@ index 1c9c1f3..a638da6 100644
          }
  
          // We have to ensure that we exit here. Otherwise, we run into
-@@ -152,11 +138,9 @@ ChildProcess vfork(const std::function<posix::exit::Status()>& main,
+@@ -155,11 +141,9 @@ ChildProcess vfork(const std::function<posix::exit::Status()>& main,
          {
              std::cerr << "core::posix::fork(): An unhandled std::exception occured in the child process:" << std::endl
                        << "  what(): " << e.what() << std::endl;
@@ -67,10 +87,10 @@ index 1c9c1f3..a638da6 100644
  
          // We have to ensure that we exit here. Otherwise, we run into
 diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index ef289ac..ed04104 100644
+index 7541e6d..9226622 100644
 --- a/tests/CMakeLists.txt
 +++ b/tests/CMakeLists.txt
-@@ -44,7 +44,6 @@ add_executable(
+@@ -38,7 +38,6 @@ add_executable(
  
    # We include an external source file to prevent from leaking
    # symbols to the outside world