From 16bcdbb2e579dad8c4e7b700e20a7fd20bca8fe1 Mon Sep 17 00:00:00 2001
From: ptrcnull <git@ptrcnull.me>
Date: Tue, 6 Aug 2024 14:35:08 +0200
Subject: [PATCH] testing/py3-columnize: build with gpep517

---
 testing/py3-columnize/APKBUILD | 20 +++++++++++++-------
 1 file changed, 13 insertions(+), 7 deletions(-)

diff --git a/testing/py3-columnize/APKBUILD b/testing/py3-columnize/APKBUILD
index edc07d8bd638..0251107515b9 100644
--- a/testing/py3-columnize/APKBUILD
+++ b/testing/py3-columnize/APKBUILD
@@ -2,30 +2,36 @@
 # Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
 pkgname=py3-columnize
 pkgver=0.3.11
-pkgrel=3
+pkgrel=4
 pkgdesc="Python module to align in columns a simple list"
 url="https://github.com/rocky/pycolumnize"
 arch="noarch"
 license="MIT"
-replaces="py-columnize" # for backwards compatibility
-provides="py-columnize=$pkgver-r$pkgrel" # for backwards compatibility
 depends="python3"
-makedepends="py3-setuptools py3-nose"
+makedepends="py3-setuptools py3-nose py3-gpep517"
 checkdepends="py3-pytest py3-mock py3-pytest-mock"
 subpackages="$pkgname-pyc"
 source="https://files.pythonhosted.org/packages/source/c/columnize/columnize-$pkgver.tar.gz"
 builddir="$srcdir"/columnize-$pkgver
 
+replaces="py-columnize" # for backwards compatibility
+provides="py-columnize=$pkgver-r$pkgrel" # for backwards compatibility
+
 build() {
-	python3 setup.py build
+	gpep517 build-wheel \
+		--wheel-dir .dist \
+		--output-fd 3 3>&1 >&2
 }
 
 check() {
-	PYTHONPATH=build/lib pytest
+	python3 -m venv --clear --without-pip --system-site-packages .testenv
+	gpep517 install-wheel --destdir .testenv --prefix '' .dist/*.whl
+	.testenv/bin/python3 -m pytest
 }
 
 package() {
-	python3 setup.py install --skip-build --root="$pkgdir"
+	gpep517 install-wheel --destdir "$pkgdir" \
+		.dist/*.whl
 }
 
 sha512sums="
-- 
GitLab