From 15b4cb0f0d153fc96e68ad47bf72b6002d3d7544 Mon Sep 17 00:00:00 2001
From: rubicon <5662-rubicon@users.gitlab.alpinelinux.org>
Date: Mon, 16 May 2022 21:49:49 +0800
Subject: [PATCH] testing/ocaml-bitstring: new aport

---
 testing/ocaml-bitstring/APKBUILD | 71 ++++++++++++++++++++++++++++++++
 1 file changed, 71 insertions(+)
 create mode 100644 testing/ocaml-bitstring/APKBUILD

diff --git a/testing/ocaml-bitstring/APKBUILD b/testing/ocaml-bitstring/APKBUILD
new file mode 100644
index 000000000000..f053ee770a3b
--- /dev/null
+++ b/testing/ocaml-bitstring/APKBUILD
@@ -0,0 +1,71 @@
+# Contributor: rubicon <rubicon@mailo.com>
+# Maintainer:
+pkgname=ocaml-bitstring
+_pkgname=bitstring
+pkgver=4.1.0
+pkgrel=0
+pkgdesc="Erlang-style bitstrings for OCaml"
+url="https://github.com/xguerin/bitstring"
+arch="all !riscv64" # restricted by ocaml
+license="LGPL-2.0-or-later"
+depends="ocaml-runtime"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
+makedepends="
+	dune
+	ocaml
+	ocaml-compiler-libs
+	ocaml-compiler-libs-repackaged-dev
+	ocaml-ppxlib-dev
+	ocaml-ppx_derivers-dev
+	ocaml-sexplib0-dev
+	ocaml-stdlib-shims
+	"
+options="!check"    # needs oUnit
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xguerin/bitstring/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+# 32-bit archs
+case "$CARCH" in
+	arm*|x86) options="$options textrels" ;;
+esac
+
+build() {
+	export OCAMLPATH=/usr/lib/ocaml
+	dune build --root . @install --no-buffer --verbose
+}
+
+check() {
+	dune runtest --no-buffer --verbose
+}
+
+package() {
+	dune install \
+		--destdir="$pkgdir" \
+		--prefix=/usr \
+		--libdir=/usr/lib/ocaml
+
+	rm -Rf "$pkgdir"/usr/doc
+}
+
+dev() {
+	default_dev
+
+	cd "$pkgdir"
+
+	local path; for path in $(find usr/lib/ocaml \( \
+			-name '*.cmt' -o \
+			-name '*.cmti' -o \
+			-name '*.cmx' -o \
+			-name '*.cmxa' -o \
+			-name '*.ml' -o \
+			-name '*.mli' \
+		\))
+	do
+		amove "$path"
+	done
+}
+
+sha512sums="
+808c2f1e12286a0a346d52b0a72008e248a3ca0fd9f99b8db9f38929d25492bcb6e65ecb7e7339c23269dd948c51e5f0fc917b13adc0c497ea4d4e5c0ed7d250  ocaml-bitstring-4.1.0.tar.gz
+"
-- 
GitLab