diff --git a/community/libmateweather/APKBUILD b/community/libmateweather/APKBUILD
index 998815a0f20e30cd29ef4d55d56482ef380b6df5..a57d9dc4e0a496950ab2fd39a07e6a31938f8008 100644
--- a/community/libmateweather/APKBUILD
+++ b/community/libmateweather/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Alan Lacerda <alacerda@alpinelinux.org>
 # Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
 pkgname=libmateweather
-pkgver=1.21.0
+pkgver=1.22.0
 pkgrel=0
 pkgdesc="A library to access weather information from online services for numerous locations"
 url="https://github.com/mate-desktop/libmateweather"
@@ -10,7 +10,8 @@ license="GPL-2.0"
 depends="mate-common"
 makedepends="libsoup-dev libtool intltool gtk+3.0-dev libxml2-utils tzdata"
 subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+	install-sh.patch"
 builddir="$srcdir/$pkgname-$pkgver"
 
 build() {
@@ -34,4 +35,5 @@ package() {
 	make DESTDIR="${pkgdir}" install
 }
 
-sha512sums="dab6d10dcf6db51a7b321690066983e06b3e237842660125b0dc36b565a04e5910f0091826091e78a9c2634932a73bf45f4749c505fd42f407f4a5f921ed68c9  libmateweather-1.21.0.tar.xz"
+sha512sums="43371fc615dda2b9042633a63ac4c1fb0b1ea43b20c783e443b0f57e10ad8fddedbd593f03bd6c942729f0a9c80484266fe1ef900d128fa4b02f80d6a80ae9bd  libmateweather-1.22.0.tar.xz
+c5b37c91f46ac09fe810cdc040c0cc8b3e457cf23f1fc8965a5e88105b441052772d3b46fd02d6ae35e91c1df81ff4618c9c61319e6ab7314e80243c72222147  install-sh.patch"
diff --git a/community/libmateweather/install-sh.patch b/community/libmateweather/install-sh.patch
new file mode 100644
index 0000000000000000000000000000000000000000..b3453421d4d309a4ec9b7d00592c80436597de8a
--- /dev/null
+++ b/community/libmateweather/install-sh.patch
@@ -0,0 +1,10 @@
+diff --git a/build-aux/install-sh b/build-aux/install-sh
+index defb86a..8175c64 100755
+--- a/build-aux/install-sh
++++ b/build-aux/install-sh
+@@ -1,4 +1,4 @@
+-#!/usr/bin/sh
++#!/bin/sh
+ # install - install a program, script, or datafile
+ 
+ scriptversion=2018-03-11.20; # UTC