Commit 1138dee5 authored by Natanael Copa's avatar Natanael Copa

main/lua-sec: add lua 5.3 and use install_if

parent 7dc38fba
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
_luaversions="5.1 5.2"
_luaversions="5.1 5.2 5.3"
pkgname=lua-sec
pkgver=0.5
pkgrel=0
pkgrel=1
pkgdesc="TLS/SSL Support for Lua"
url="https://github.com/brunoos/luasec/wiki"
arch="all"
......@@ -14,7 +14,6 @@ makedepends="openssl-dev"
install=
subpackages="$pkgname-doc"
for _i in $_luaversions; do
depends="$depends lua$_i-sec"
makedepends="$makedepends lua$_i-dev"
subpackages="$subpackages lua$_i-sec:split_${_i/./_}"
done
......@@ -57,6 +56,7 @@ package() {
_split() {
local d= _ver=$1
pkgdesc="TLS/SSL Support for Lua $_ver"
install_if="lua$_ver $pkgname=$pkgver-r$pkgrel"
replaces="$pkgname"
depends="lua$_ver-socket"
for d in usr/lib/lua usr/share/lua; do
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment