diff --git a/community/amazfish/APKBUILD b/community/amazfish/APKBUILD
index 352767e3b899e89bca53e88af4aea87c6df3c06e..f62f5fe54a8d38de9532ab271fd48915f34fd4a6 100644
--- a/community/amazfish/APKBUILD
+++ b/community/amazfish/APKBUILD
@@ -1,10 +1,10 @@
 # Contributor: Bart Ribbers <bribbers@disroot.org>
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=amazfish
-pkgver=1.9.8
-pkgrel=2
-_commit_qble="d531225632b8872997e9facc8bcf15423a9b96c0"
-_commit_libwatchfish="e3bf99e47c8c339b15eb4c8d6a485c22e9c7c2cd"
+pkgver=2.0.1
+pkgrel=0
+_commit_qble="2c287455387892e9158c108679921eaf0581a7fa"
+_commit_libwatchfish="ec302cd25d4605e56148a750f2f75fb5c641cfee"
 pkgdesc="Companion application for Huami Devices (such as Amazfit Bip, Cor, MiBand2/3 and GTS and GTS) and the Pinetime Infinitime"
 url="https://github.com/piggz/harbour-amazfish"
 # armhf blocked by kdb
@@ -25,6 +25,7 @@ makedepends="
 source="https://github.com/piggz/harbour-amazfish/archive/$pkgver/harbour-amazfish-$pkgver.tar.gz
 	https://github.com/piggz/qble/archive/$_commit_qble/qble-$_commit_qble.tar.gz
 	https://github.com/piggz/libwatchfish/archive/$_commit_libwatchfish/libwatchfish-$_commit_libwatchfish.tar.gz
+	amazfish-launcher.sh
 	amazfish.desktop
 	"
 options="!check" # No tests
@@ -49,12 +50,16 @@ package() {
 	make INSTALL_ROOT="$pkgdir" install
 
 	install -Dm644 "$srcdir"/amazfish.desktop -t "$pkgdir"/etc/xdg/autostart/
+	install -Dm755 "$srcdir"/amazfish-launcher.sh "$pkgdir"/usr/libexec/amazfish-launcher
 
 	# We don't ship systemd
 	rm -r "$pkgdir"/usr/lib/systemd
 }
 
-sha512sums="2d74a8f2b7439693aae8d47c00fb8d6d134a9eff27d399a084c1282add3d30e1def5f32126eb5479f5711a4cfdc5bffbbbe0b2548879b3f8adad837db67b6776  harbour-amazfish-1.9.8.tar.gz
-4ac649f4f532ac644535a51b4c1d38d27f30e8b0c56afc2c46f5593fd95d9c17661afa26f352023b87cf30c390206644acc6763d0519d5f9895784a64d27dbc6  qble-d531225632b8872997e9facc8bcf15423a9b96c0.tar.gz
-79a1f258c73b6ecf73ad757695cd5656a0ab73aa319f986ae2a3132906947f1bdecfa834de711e67ae56129003ff83379a2d7ded3d9add7b684b3d14e83af885  libwatchfish-e3bf99e47c8c339b15eb4c8d6a485c22e9c7c2cd.tar.gz
-3f1677d7b954bea6bcf2336edd29915f1d8b5d34acf9b8bd9ed774ae2b595e64c93cb707d80f5f022f3fd5d4ca7c820bac222d2df0c8fa4f6b55ac7ba40e81d6  amazfish.desktop"
+sha512sums="
+f71f64fa2eb832cfbf1b56ff0338cf0f25054ce028754ecf2f02a6d22ff34a421651bf39f5e0f869d713eeeed4852ca4cbe154761a232e928e2250ee92a6eadf  harbour-amazfish-2.0.1.tar.gz
+55207138b317b30b108b15d3fe07b4c5a2ef959ef707930bffa5339ce846308e264c791bde0c7d7839d61966463bfd91d894ba473f6e03537b901bc74d3a51b1  qble-2c287455387892e9158c108679921eaf0581a7fa.tar.gz
+79ddcc7b68b78a5dcaab1c8efe10a623af198ec9c71bc3a971fe9baa267d18b0bc6b538c7ed1c41bfcdf86dc5c21fc5bfd25b0e976f0e82d45e88ec8636b6368  libwatchfish-ec302cd25d4605e56148a750f2f75fb5c641cfee.tar.gz
+a17c0d6578e0d6878099f9c913e54100c44dbb94cf8803f2780d5709ec08136daa832ec2ffe947fb8a91e02320f01041d0e763bcc08350270af36d89f767ca14  amazfish-launcher.sh
+930f2cae5f88559a83dd46d11d2161a9239efdd46ad6b91dc530eb4a7863f197a7865f9599973b71bcc7d1e2346c848ea7b9a57f5b714560d101b0f384c0f4d1  amazfish.desktop
+"
diff --git a/community/amazfish/amazfish-launcher.sh b/community/amazfish/amazfish-launcher.sh
new file mode 100644
index 0000000000000000000000000000000000000000..ef2c8b7c12f34618977b24412955656a657e128a
--- /dev/null
+++ b/community/amazfish/amazfish-launcher.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+# We need to kill any existing pipewire instance to restore sound
+pkill -u "${USER}" -x harbour-amazfishd 1>/dev/null 2>&1
+
+exec /usr/bin/harbour-amazfishd
diff --git a/community/amazfish/amazfish.desktop b/community/amazfish/amazfish.desktop
index 8be8c61b0d99f70aec62f6e58ae847a29316230b..759091ad40dc7c96bed4c749b631c38c0560be83 100644
--- a/community/amazfish/amazfish.desktop
+++ b/community/amazfish/amazfish.desktop
@@ -2,6 +2,6 @@
 Name=amazfish
 Comment=Start amazfish
 Type=Application
-Exec=/usr/bin/harbour-amazfishd
+Exec=/usr/libexec/amazfish-launcher
 TryExec=/usr/bin/harbour-amazfishd
 Terminal=false