diff --git a/community/py3-netjsonconfig/APKBUILD b/community/py3-netjsonconfig/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..e37c793449dd7512a8280728d259d3af309cc713
--- /dev/null
+++ b/community/py3-netjsonconfig/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Alex Denes <caskd@redxen.eu>
+# Maintainer: Alex Denes <caskd@redxen.eu>
+pkgname=py3-netjsonconfig
+_pkgname=netjsonconfig
+pkgver=0.9.1
+pkgrel=0
+pkgdesc="Python library that converts NetJSON DeviceConfiguration objects into real router configurations"
+url="http://netjsonconfig.openwisp.org/"
+arch="noarch"
+license="GPL-3.0-only"
+depends="
+	py3-pip
+	py3-jinja2
+	py3-jsonschema
+	py3-six
+"
+checkdepends="
+	py3-nose>=2
+"
+makedepends="py3-setuptools_scm"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # requires nose > 2.0
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py test
+}
+
+package() {
+	python3 setup.py install --root "$pkgdir"
+}
+
+sha512sums="
+b5d9fe026f94cf8f34b7475766c556dff4864f6ebac3f4b8533988e894a855180c1a3e1fa7bbe51e39e2dfbb6af70d9e6d4bd90c082c5ed4f5474dbd72231ed6  netjsonconfig-0.9.1.tar.gz
+"