From 0d4a016c56baa8168148dbb6becf60f1843a2a8e Mon Sep 17 00:00:00 2001
From: Bart Ribbers <bribbers@disroot.org>
Date: Fri, 4 Dec 2020 12:19:56 +0100
Subject: [PATCH] testing/py3-upnpclient: new aport

---
 testing/py3-upnpclient/APKBUILD | 44 +++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
 create mode 100644 testing/py3-upnpclient/APKBUILD

diff --git a/testing/py3-upnpclient/APKBUILD b/testing/py3-upnpclient/APKBUILD
new file mode 100644
index 000000000000..bc81cfa6b71e
--- /dev/null
+++ b/testing/py3-upnpclient/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-upnpclient
+pkgver=1.0.3
+pkgrel=0
+pkgdesc="Library for accessing uPnP devices"
+url="https://github.com/flyte/upnpclient"
+arch="noarch"
+license="MIT"
+depends="
+	py3-dateutil
+	py3-ifaddr
+	py3-lxml
+	py3-requests
+	py3-six
+	python3
+	"
+makedepends="
+	py3-pytest-runner
+	poetry
+	py3-pip
+	"
+checkdepends="
+	py3-mock
+	py3-pytest
+	py3-pytest-runner
+	"
+source="https://github.com/flyte/upnpclient/archive/$pkgver/upnpclient-$pkgver.tar.gz"
+options="!check" # Depends on itself
+builddir="$srcdir/upnpclient-$pkgver"
+
+build() {
+	poetry build --format wheel
+}
+
+check() {
+	PYTHONPATH="$PWD/dist" pytest
+}
+
+package() {
+	pip install --isolated --root="$pkgdir" --ignore-installed --no-deps dist/*.whl
+}
+
+sha512sums="034460b9821e99130b557a628c7b98537d2e1781eaf2819fc27a19e2ea63e2a001299bee0a615f7edc78c816b02923df6a51414b1f95b738252e26ff3562df94  upnpclient-1.0.3.tar.gz"
-- 
GitLab