diff --git a/main/busybox/0001-adduser-prevent-creation-from-invalid-entry-without-.patch b/main/busybox/0001-adduser-prevent-creation-from-invalid-entry-without-.patch
deleted file mode 100644
index 0bca3b7b514eacecc489d70c2bc959320443e830..0000000000000000000000000000000000000000
--- a/main/busybox/0001-adduser-prevent-creation-from-invalid-entry-without-.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 8f0f1d6c9315d10dacdb26ff6cc9059a7a565eb3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
-Date: Sat, 12 Jan 2019 00:01:34 +0100
-Subject: [PATCH] adduser: prevent creation from invalid entry without -s
-
-If -s is not specified adduser uses get_shell_name() to determine the
-shell it should use for the newly created user. If SHELL is not set this
-function uses getpwnam(3) to determine the shell of the current user and
-returns that.
-
-getpwnam(3) uses static storage and is called again in passwd_study()
-overwriting the memory location get_shell_name() returned a pointer to.
-Thereby potentially creating an entry with an invalid shell.
-
-To fix this xstrdup() the return value of get_shell_name(). This
-approach is also used by crond, ifupdown and svlogd.
----
- loginutils/adduser.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/loginutils/adduser.c b/loginutils/adduser.c
-index b2b5be5b3..7e5a85c33 100644
---- a/loginutils/adduser.c
-+++ b/loginutils/adduser.c
-@@ -198,7 +198,7 @@ int adduser_main(int argc UNUSED_PARAM, char **argv)
- 
- 	pw.pw_gecos = (char *)"Linux User,,,";
- 	/* We assume that newly created users "inherit" root's shell setting */
--	pw.pw_shell = (char *)get_shell_name();
-+	pw.pw_shell = xstrdup(get_shell_name());
- 	pw.pw_dir = NULL;
- 
- 	opts = getopt32long(argv, "^"
diff --git a/main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch b/main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch
index ba289a230b08b6040f31295800ba5abc62dcbc7b..f328779a8deb7833f5355eb5ca10711883dc3e30 100644
--- a/main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch
+++ b/main/busybox/0012-udhcpc-Don-t-background-if-n-is-given.patch
@@ -1,4 +1,4 @@
-From f945fb1489f7d285c7f17d64fbe259637d3ef790 Mon Sep 17 00:00:00 2001
+From 36a09262a3a82407ddd8a789734dfde1e6d46bfa Mon Sep 17 00:00:00 2001
 From: Natanael Copa <ncopa@alpinelinux.org>
 Date: Thu, 6 Jul 2017 13:39:15 +0200
 Subject: [PATCH] udhcpc: Don't background if -n is given
@@ -6,15 +6,44 @@ Subject: [PATCH] udhcpc: Don't background if -n is given
 we need add -b to our udhcpc options to prevent boot forever if there are no
 dhcp server. We also need a way for users to disable this behavior by making
 it possible to set -n option at runtime.
+
+Since busybox 1.31.0 -b takes precedence over -n [0]. However, since we
+enable -b instead of -n by default (through our busyboxconfig) this is
+not desired, this commit therefore also reverts the upstream patch
+introducing this change.
+
+See also: https://bugs.busybox.net/11691
+
+[0]: https://git.busybox.net/busybox/commit/?id=87e216294af9eec39c0c1d553555f8a98c15db38
 ---
- networking/udhcp/dhcpc.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
+ networking/udhcp/d6_dhcpc.c |  8 +-------
+ networking/udhcp/dhcpc.c    | 20 +++++++-------------
+ 2 files changed, 8 insertions(+), 20 deletions(-)
 
+diff --git a/networking/udhcp/d6_dhcpc.c b/networking/udhcp/d6_dhcpc.c
+index 422b88882..dab9d33a0 100644
+--- a/networking/udhcp/d6_dhcpc.c
++++ b/networking/udhcp/d6_dhcpc.c
+@@ -1365,13 +1365,7 @@ int udhcpc6_main(int argc UNUSED_PARAM, char **argv)
+ 					bb_info_msg("no lease, forking to background");
+ 					client_background();
+ 					/* do not background again! */
+-					opt = ((opt & ~(OPT_b|OPT_n)) | OPT_f);
+-					/* ^^^ also disables -n (-b takes priority over -n):
+-					 * ifup's default udhcpc options are -R -n,
+-					 * and users want to be able to add -b
+-					 * (in a config file) to make it background
+-					 * _and not exit_.
+-					 */
++					opt = ((opt & ~OPT_b) | OPT_f);
+ 				} else
+ #endif
+ 				if (opt & OPT_n) { /* abort if no lease */
 diff --git a/networking/udhcp/dhcpc.c b/networking/udhcp/dhcpc.c
-index 0b14b0332..623b87fbb 100644
+index 739870bee..d09e2acca 100644
 --- a/networking/udhcp/dhcpc.c
 +++ b/networking/udhcp/dhcpc.c
-@@ -1469,19 +1469,19 @@ int udhcpc_main(int argc UNUSED_PARAM, char **argv)
+@@ -1478,25 +1478,19 @@ int udhcpc_main(int argc UNUSED_PARAM, char **argv)
  				}
   leasefail:
  				udhcp_run_script(NULL, "leasefail");
@@ -25,16 +54,23 @@ index 0b14b0332..623b87fbb 100644
 +				}
  #if BB_MMU /* -b is not supported on NOMMU */
  				if (opt & OPT_b) { /* background if no lease */
- 					bb_error_msg("no lease, forking to background");
+ 					bb_info_msg("no lease, forking to background");
  					client_background();
  					/* do not background again! */
- 					opt = ((opt & ~OPT_b) | OPT_f);
+-					opt = ((opt & ~(OPT_b|OPT_n)) | OPT_f);
+-					/* ^^^ also disables -n (-b takes priority over -n):
+-					 * ifup's default udhcpc options are -R -n,
+-					 * and users want to be able to add -b
+-					 * (in a config file) to make it background
+-					 * _and not exit_.
+-					 */
 -				} else
 -#endif
 -				if (opt & OPT_n) { /* abort if no lease */
--					bb_error_msg("no lease, failing");
+-					bb_info_msg("no lease, failing");
 -					retval = 1;
 -					goto ret;
++					opt = ((opt & ~OPT_b) | OPT_f);
  				}
 +#endif
  				/* wait before trying again */
diff --git a/main/busybox/0015-ip-print-dadfailed-flag.patch b/main/busybox/0015-ip-print-dadfailed-flag.patch
deleted file mode 100644
index 96c26bb04e0ff20d7626869b0d5fc2de81b109cc..0000000000000000000000000000000000000000
--- a/main/busybox/0015-ip-print-dadfailed-flag.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From a8c618c63e88064ae07d34f3c92469624e097376 Mon Sep 17 00:00:00 2001
-From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
-Date: Mon, 31 Dec 2018 19:32:21 +0200
-Subject: [PATCH] ip: print dadfailed flag
-
-Signed-off-by: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
----
- networking/libiproute/ipaddress.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/networking/libiproute/ipaddress.c b/networking/libiproute/ipaddress.c
-index 9ec665b69..d088caf4c 100644
---- a/networking/libiproute/ipaddress.c
-+++ b/networking/libiproute/ipaddress.c
-@@ -327,6 +327,10 @@ static int FAST_FUNC print_addrinfo(const struct sockaddr_nl *who UNUSED_PARAM,
- 		ifa->ifa_flags &= ~IFA_F_TENTATIVE;
- 		printf("tentative ");
- 	}
-+	if (ifa->ifa_flags & IFA_F_DADFAILED) {
-+		ifa->ifa_flags &= ~IFA_F_DADFAILED;
-+		printf("dadfailed ");
-+	}
- 	if (ifa->ifa_flags & IFA_F_DEPRECATED) {
- 		ifa->ifa_flags &= ~IFA_F_DEPRECATED;
- 		printf("deprecated ");
--- 
-2.20.1
-
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 506a27343d55171c72bccd7d11caf8851af7f35d..18b4cc91cd77f4ea44670511888c0027260cf523 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -2,8 +2,8 @@
 # Contributor: Oliver Smith <ollieparanoid@bitmessage.ch>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=busybox
-pkgver=1.30.1
-pkgrel=2
+pkgver=1.31.0
+pkgrel=0
 pkgdesc="Size optimized toolbox of many common UNIX utilities"
 url="https://busybox.net/"
 arch="all"
@@ -21,7 +21,6 @@ triggers="busybox.trigger=/bin:/usr/bin:/sbin:/usr/sbin:/lib/modules/*"
 source="https://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
 	0001-nologin-Install-applet-to-sbin-instead-of-usr-sbin.patch
 	0001-adduser-default-to-sbin-nologin-as-shell-for-system-.patch
-	0001-adduser-prevent-creation-from-invalid-entry-without-.patch
 	0001-properly-fix-wget-https-support.patch
 	0002-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch
 	0003-ash-exec-busybox.static.patch
@@ -35,8 +34,6 @@ source="https://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
 	0012-udhcpc-Don-t-background-if-n-is-given.patch
 	0013-testsuite-fix-cpio-tests.patch
 	0014-miscutils-microcom-Fixed-segfault.patch
-	0015-ip-print-dadfailed-flag.patch
-	CVE-2019-5747.patch
 
 	acpid.logrotate
 	busyboxconfig
@@ -202,10 +199,9 @@ ssl_client() {
 }
 
 
-sha512sums="c18b3d06356d4708b4b0e89d23500d2fe494da9f6aac09c0c19a2e5145ba2bfe8261088eae6562c900996b50c5a9c20459f908069267898c8f86fe3b0b7bd80b  busybox-1.30.1.tar.bz2
+sha512sums="cd58f0b2b6e3bb1b771fcf3d15f420518fb9b10086a45cfb1d7f136ac035be89eec28f9350e42b3fc38454d8bef9190eae0376497487c73785e8fde44c793730  busybox-1.31.0.tar.bz2
 ead3403578c071c2216de17ab0543984c1f1509c12c062f03af49141547c3ea21356f3e8f0f0695550f05a41a1379dd73fc3cc18dcd78addbb411f247351e353  0001-nologin-Install-applet-to-sbin-instead-of-usr-sbin.patch
 a2787a3ecaf6746dadef62166e8ee6ecaa166147e5ad8b917c5838536057c875bab5f9cf40c3e05eba74d575484ac662929ac3799d58432d3a99ac46f364f302  0001-adduser-default-to-sbin-nologin-as-shell-for-system-.patch
-06a341de7b34bbe5d7981366772c2ce46599af3e9640d114aa28f7ba4936489fc00c58d4b09c546409e383ef70ca51da179223a9ef53ed51f3575e652506e08e  0001-adduser-prevent-creation-from-invalid-entry-without-.patch
 78f4c602e518b01d600824cea246992e58961f2a65737741b1a2283c96900f11504b791423f2482eec79090a9f612b2088c66f6c9f22153daca08b7fe534cca5  0001-properly-fix-wget-https-support.patch
 d8694293edc8cd55cecafeb902f03c01af318e13966f399365cf792b840793891ac086bb67ef83e7a5a2e01b246497a6c6511cb6a856834f6672dee4bca76896  0002-fsck-resolve-LABEL-.-UUID-.-spec-to-device.patch
 8c34dd5ce9a6e84279fa6494cbae0b254778976f341af1d0ccc2a3afb405fb22d374e9623ea83d1500da77c7463db2ed5218d2c9f49350a21114bd0bb17fd87d  0003-ash-exec-busybox.static.patch
@@ -216,14 +212,12 @@ f96d66ce5a0295a2459a2c49c281b64e016de675ebd31a49af18cb06f3498fe27dfbc8667324b439
 2c56906dac70dea6276e4c573707cb06c4c8b53defcd33b1e5a28f928e7dafe905a52ce40571de430e4af7e00a75ecc0f249d2fec02da5f3d9edd4e904919a35  0008-fbsplash-support-image-and-bar-alignment-and-positio.patch
 907aef47c88f60e93bcd290eb43102721978ab6fc6eca52914172801ace7306ae8b11f38ed8b086452bbf46d75424740161e4f1e7840a485f0f78024455f902b  0009-depmod-support-generating-kmod-binary-index-files.patch
 3b13ba6bd9b697e48864cb5376849c1ac95b30650e3e27605cc05edf4fdc1ecbb4c4503d4fe9012a581bcd660f6bb44d644575cf437d30423614cb83ee92c22c  0010-Add-flag-for-not-following-symlinks-when-recursing.patch
-025ad19f4e0cd299f11eba4a0c852c166fc91787756838f9c755405dad924fd1fe3c08067b938e14f9d8c609881d2ce5915152810e855eaa5ca510a76650069e  0012-udhcpc-Don-t-background-if-n-is-given.patch
+e78a10d460e9cef545621b7b6d9da604865dc04e3a8202bdce1db9d697255818acc1150397c18101a104bc84b87de61209687e1fdc52cc244fd4fe4642a03b4e  0012-udhcpc-Don-t-background-if-n-is-given.patch
 d8926f0e4ed7d2fe5af89ff2a944d781b45b109c9edf1ef2591e7bce2a8bbadd7c8ca814cb3c928ae09027d9603434fe70496f308d701f3d42260ebd1e9e9b29  0013-testsuite-fix-cpio-tests.patch
 8cb91903f2be3620b5500a4e8f4190537c93601282510b82303c3b516141b36ab872aeff5a7f5ae00f270439abab862ceabda531bdf180643da165b2f3b35d9f  0014-miscutils-microcom-Fixed-segfault.patch
-2fdf01e4bb26a3b6fd7ff73649f15eff599d38db1bc61a699576ec9caae2fb37c49d689baca8b1a3a7b2999fbe04751da897518c2fb42d6f21756b468aa7599d  0015-ip-print-dadfailed-flag.patch
-6952770be92a980174691ac65fda778eaafd23bf8da63ad62149f2cb0f289bef216bb512ae5e013328b3bd5289a351124d22dd819b1e3116cc2244b435eb7287  CVE-2019-5747.patch
 aa93095e20de88730f526c6f463cef711b290b9582cdbd8c1ba2bd290019150cbeaa7007c2e15f0362d5b9315dd63f60511878f0ea05e893f4fdfb4a54af3fb1  acpid.logrotate
-fc1f4e44e3f7874a8036d48e039c45e08761007a0f4f9b6f242b63f57b641b7609f47cffc620e08ab6384885a0bec822f840e79567c304dc1944124f27a9f4ad  busyboxconfig
-c6f0fc8e6f5a166309d8548bd1a7e11a2bc71b67c1222567485329602b55fbd4e12b627fa092fff3c269ebc01f20eb55ae7fca12f7c655afe0e563af4fd2c873  busyboxconfig-extras
+69e10d1793a7ef6bd4bce04f556c487b98b75652adef629bdf7bfce7dff2b99dec8662730fb2333f8a8e76db513c6249091357b1a5bd6183e0b08f790249296b  busyboxconfig
+5f9739b9d0c1ba5d77e3153c373593a1bcb813cf466f951b00a2a040262e5077fb13c1a7aa17d67d1533a473bfcacc1a22833b7f491b4dde9dcb5638ad585f9a  busyboxconfig-extras
 0becc2186d6c32fb0c401cf7bc0e46268b38ce8892db33be1daf40273024c1c02d518283f44086a313a2ccef34230a1d945ec148cc173f26e6aa9d88a7426e54  bbsuid.c
 b993ce589685d5d1f806153d0b7f71657f2d37556654ec60884130a40f09acc4944a13e0a4d02914000bedd779e5a35da08c760fed5f7ca5b601243aff7ba2c9  dad.if-up
 646ad9aefe3596d0170d92c8506ca1846e43b5b83cbef97ae565f15ffa7b14665a8c7061bc69c608c043f834c134c5d63f042509f8999031e89163508a868e46  ssl_client.c"
diff --git a/main/busybox/CVE-2019-5747.patch b/main/busybox/CVE-2019-5747.patch
deleted file mode 100644
index f81f02b30ca650d4e8b3ededb2f98998eed16040..0000000000000000000000000000000000000000
--- a/main/busybox/CVE-2019-5747.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-From 74d9f1ba37010face4bd1449df4d60dd84450b06 Mon Sep 17 00:00:00 2001
-From: Denys Vlasenko <vda.linux@googlemail.com>
-Date: Mon, 7 Jan 2019 15:33:42 +0100
-Subject: udhcpc: when decoding DHCP_SUBNET, ensure it is 4 bytes long
-
-function                                             old     new   delta
-udhcp_run_script                                     795     801      +6
-
-Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
----
- networking/udhcp/common.c | 2 +-
- networking/udhcp/common.h | 2 +-
- networking/udhcp/dhcpc.c  | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/networking/udhcp/common.c b/networking/udhcp/common.c
-index 4c2221b77..fc4de5716 100644
---- a/networking/udhcp/common.c
-+++ b/networking/udhcp/common.c
-@@ -302,7 +302,7 @@ uint8_t* FAST_FUNC udhcp_get_option32(struct dhcp_packet *packet, int code)
- {
- 	uint8_t *r = udhcp_get_option(packet, code);
- 	if (r) {
--		if (r[-1] != 4)
-+		if (r[-OPT_DATA + OPT_LEN] != 4)
- 			r = NULL;
- 	}
- 	return r;
-diff --git a/networking/udhcp/common.h b/networking/udhcp/common.h
-index 9511152ff..62f9a2a4a 100644
---- a/networking/udhcp/common.h
-+++ b/networking/udhcp/common.h
-@@ -119,7 +119,7 @@ enum {
- //#define DHCP_TIME_SERVER      0x04 /* RFC 868 time server (32-bit, 0 = 1.1.1900) */
- //#define DHCP_NAME_SERVER      0x05 /* IEN 116 _really_ ancient kind of NS */
- //#define DHCP_DNS_SERVER       0x06
--//#define DHCP_LOG_SERVER       0x07 /* port 704 UDP log (not syslog)
-+//#define DHCP_LOG_SERVER       0x07 /* port 704 UDP log (not syslog) */
- //#define DHCP_COOKIE_SERVER    0x08 /* "quote of the day" server */
- //#define DHCP_LPR_SERVER       0x09
- #define DHCP_HOST_NAME          0x0c /* 12: either client informs server or server gives name to client */
-diff --git a/networking/udhcp/dhcpc.c b/networking/udhcp/dhcpc.c
-index 5b3fd531c..dcec8cdfd 100644
---- a/networking/udhcp/dhcpc.c
-+++ b/networking/udhcp/dhcpc.c
-@@ -531,7 +531,7 @@ static char **fill_envp(struct dhcp_packet *packet)
- 		temp = udhcp_get_option(packet, code);
- 		*curr = xmalloc_optname_optval(temp, &dhcp_optflags[i], opt_name);
- 		putenv(*curr++);
--		if (code == DHCP_SUBNET) {
-+		if (code == DHCP_SUBNET && temp[-OPT_DATA + OPT_LEN] == 4) {
- 			/* Subnet option: make things like "$ip/$mask" possible */
- 			uint32_t subnet;
- 			move_from_unaligned32(subnet, temp);
--- 
-cgit v1.2.1
-
diff --git a/main/busybox/busyboxconfig b/main/busybox/busyboxconfig
index ae253f3503c0fd472e79c4a0e9c28521ea2c3f30..eb0bead9a9427dfd5ed9dd3c9204961b714133e8 100644
--- a/main/busybox/busyboxconfig
+++ b/main/busybox/busyboxconfig
@@ -1,7 +1,7 @@
 #
 # Automatically generated make config: don't edit
-# Busybox version: 1.30.0
-# Wed Feb 13 21:57:17 2019
+# Busybox version: 1.31.0
+# Tue Jul 23 12:11:42 2019
 #
 CONFIG_HAVE_DOT_CONFIG=y
 
@@ -34,6 +34,7 @@ CONFIG_FEATURE_SUID=y
 CONFIG_BUSYBOX_EXEC_PATH="/bin/busybox"
 # CONFIG_SELINUX is not set
 # CONFIG_FEATURE_CLEAN_UP is not set
+CONFIG_FEATURE_SYSLOG_INFO=y
 CONFIG_FEATURE_SYSLOG=y
 CONFIG_PLATFORM_LINUX=y
 
@@ -236,7 +237,6 @@ CONFIG_EXPR_MATH_SUPPORT_64=y
 CONFIG_FACTOR=y
 CONFIG_FALSE=y
 CONFIG_FOLD=y
-CONFIG_FSYNC=y
 CONFIG_HEAD=y
 CONFIG_FEATURE_FANCY_HEAD=y
 CONFIG_HOSTID=y
@@ -303,6 +303,7 @@ CONFIG_STTY=y
 CONFIG_SUM=y
 CONFIG_SYNC=y
 CONFIG_FEATURE_SYNC_FANCY=y
+CONFIG_FSYNC=y
 CONFIG_TAC=y
 CONFIG_TAIL=y
 CONFIG_FEATURE_FANCY_TAIL=y
@@ -640,6 +641,7 @@ CONFIG_FEATURE_MDEV_RENAME=y
 CONFIG_FEATURE_MDEV_RENAME_REGEXP=y
 CONFIG_FEATURE_MDEV_EXEC=y
 CONFIG_FEATURE_MDEV_LOAD_FIRMWARE=y
+# CONFIG_FEATURE_MDEV_DAEMON is not set
 CONFIG_MESG=y
 CONFIG_FEATURE_MESG_ENABLE_ONLY_GROUP=y
 # CONFIG_MKE2FS is not set
@@ -787,6 +789,7 @@ CONFIG_HDPARM=y
 # CONFIG_I2CSET is not set
 # CONFIG_I2CDUMP is not set
 # CONFIG_I2CDETECT is not set
+# CONFIG_I2CTRANSFER is not set
 CONFIG_INOTIFYD=y
 CONFIG_LESS=y
 CONFIG_FEATURE_LESS_MAXLINES=9999999
@@ -820,6 +823,7 @@ CONFIG_RFKILL=y
 CONFIG_SETSERIAL=y
 CONFIG_STRINGS=y
 CONFIG_TIME=y
+# CONFIG_TS is not set
 CONFIG_TTYSIZE=y
 # CONFIG_UBIATTACH is not set
 # CONFIG_UBIDETACH is not set
@@ -947,6 +951,7 @@ CONFIG_SLATTACH=y
 # CONFIG_FEATURE_TELNETD_INETD_WAIT is not set
 # CONFIG_TFTP is not set
 # CONFIG_FEATURE_TFTP_PROGRESS_BAR is not set
+# CONFIG_FEATURE_TFTP_HPA_COMPAT is not set
 # CONFIG_TFTPD is not set
 # CONFIG_FEATURE_TFTP_GET is not set
 # CONFIG_FEATURE_TFTP_PUT is not set
@@ -1156,6 +1161,7 @@ CONFIG_ASH_CMDCMD=y
 #
 CONFIG_FEATURE_SH_MATH=y
 CONFIG_FEATURE_SH_MATH_64=y
+CONFIG_FEATURE_SH_MATH_BASE=y
 CONFIG_FEATURE_SH_EXTRA_QUIET=y
 # CONFIG_FEATURE_SH_STANDALONE is not set
 # CONFIG_FEATURE_SH_NOFORK is not set
diff --git a/main/busybox/busyboxconfig-extras b/main/busybox/busyboxconfig-extras
index 95d55f302bba5ecd626911402afa168d05c2dbe0..9c70c1f785f8bafddbf8dae10a463db6996843a5 100644
--- a/main/busybox/busyboxconfig-extras
+++ b/main/busybox/busyboxconfig-extras
@@ -1,7 +1,7 @@
 #
 # Automatically generated make config: don't edit
-# Busybox version: 1.30.0
-# Wed Feb 13 21:54:59 2019
+# Busybox version: 1.31.0
+# Tue Jul 23 12:14:13 2019
 #
 CONFIG_HAVE_DOT_CONFIG=y
 
@@ -34,6 +34,7 @@ CONFIG_FEATURE_INSTALLER=y
 CONFIG_BUSYBOX_EXEC_PATH="/proc/self/exe"
 # CONFIG_SELINUX is not set
 # CONFIG_FEATURE_CLEAN_UP is not set
+CONFIG_FEATURE_SYSLOG_INFO=y
 CONFIG_FEATURE_SYSLOG=y
 CONFIG_PLATFORM_LINUX=y
 
@@ -236,7 +237,6 @@ CONFIG_GZIP_FAST=0
 # CONFIG_FACTOR is not set
 # CONFIG_FALSE is not set
 # CONFIG_FOLD is not set
-# CONFIG_FSYNC is not set
 # CONFIG_HEAD is not set
 # CONFIG_FEATURE_FANCY_HEAD is not set
 # CONFIG_HOSTID is not set
@@ -299,6 +299,7 @@ CONFIG_GZIP_FAST=0
 # CONFIG_SUM is not set
 # CONFIG_SYNC is not set
 # CONFIG_FEATURE_SYNC_FANCY is not set
+# CONFIG_FSYNC is not set
 # CONFIG_TAC is not set
 # CONFIG_TAIL is not set
 # CONFIG_FEATURE_FANCY_TAIL is not set
@@ -624,6 +625,7 @@ CONFIG_DEFAULT_DEPMOD_FILE=""
 # CONFIG_FEATURE_MDEV_RENAME_REGEXP is not set
 # CONFIG_FEATURE_MDEV_EXEC is not set
 # CONFIG_FEATURE_MDEV_LOAD_FIRMWARE is not set
+# CONFIG_FEATURE_MDEV_DAEMON is not set
 # CONFIG_MESG is not set
 # CONFIG_FEATURE_MESG_ENABLE_ONLY_GROUP is not set
 # CONFIG_MKE2FS is not set
@@ -763,6 +765,7 @@ CONFIG_FEATURE_CROND_DIR=""
 # CONFIG_I2CSET is not set
 # CONFIG_I2CDUMP is not set
 # CONFIG_I2CDETECT is not set
+# CONFIG_I2CTRANSFER is not set
 # CONFIG_INOTIFYD is not set
 # CONFIG_LESS is not set
 CONFIG_FEATURE_LESS_MAXLINES=0
@@ -796,6 +799,7 @@ CONFIG_READAHEAD=y
 # CONFIG_SETSERIAL is not set
 # CONFIG_STRINGS is not set
 # CONFIG_TIME is not set
+# CONFIG_TS is not set
 # CONFIG_TTYSIZE is not set
 # CONFIG_UBIATTACH is not set
 # CONFIG_UBIDETACH is not set
@@ -923,6 +927,7 @@ CONFIG_FEATURE_TELNETD_STANDALONE=y
 CONFIG_FEATURE_TELNETD_INETD_WAIT=y
 CONFIG_TFTP=y
 CONFIG_FEATURE_TFTP_PROGRESS_BAR=y
+CONFIG_FEATURE_TFTP_HPA_COMPAT=y
 CONFIG_TFTPD=y
 CONFIG_FEATURE_TFTP_GET=y
 CONFIG_FEATURE_TFTP_PUT=y
@@ -1132,6 +1137,7 @@ CONFIG_BASH_IS_NONE=y
 #
 # CONFIG_FEATURE_SH_MATH is not set
 # CONFIG_FEATURE_SH_MATH_64 is not set
+# CONFIG_FEATURE_SH_MATH_BASE is not set
 # CONFIG_FEATURE_SH_EXTRA_QUIET is not set
 # CONFIG_FEATURE_SH_STANDALONE is not set
 # CONFIG_FEATURE_SH_NOFORK is not set