From 0b5f0b28a6f08df4f29af5a7e356faa4e3ca2a34 Mon Sep 17 00:00:00 2001
From: ptrcnull <git@ptrcnull.me>
Date: Fri, 8 Jul 2022 19:04:16 +0200
Subject: [PATCH] community/py3-jupyter_core: upgrade to 4.11.1

---
 community/py3-jupyter_core/APKBUILD | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/community/py3-jupyter_core/APKBUILD b/community/py3-jupyter_core/APKBUILD
index 27624f0f7752..354074706ec0 100644
--- a/community/py3-jupyter_core/APKBUILD
+++ b/community/py3-jupyter_core/APKBUILD
@@ -1,20 +1,20 @@
 # Contributor: Aiden Grossman <agrossman154@yahoo.com>
 # Maintainer: Aiden Grossman <agrossman154@yahoo.com>
 pkgname=py3-jupyter_core
-pkgver=4.10.0
+pkgver=4.11.1
 pkgrel=0
 pkgdesc="Core Jupyter functionality"
 url="https://github.com/jupyter/jupyter_core"
 arch="noarch"
 license="BSD-3-Clause"
 depends="py3-traitlets"
-makedepends="py3-setuptools"
+makedepends="py3-hatchling py3-build py3-installer"
 checkdepends="py3-pytest"
 source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/jupyter_core/archive/refs/tags/$pkgver.tar.gz"
 builddir="$srcdir/jupyter_core-$pkgver"
 
 build() {
-	python3 setup.py build
+	python3 -m build --no-isolation --wheel
 }
 
 check() {
@@ -25,13 +25,13 @@ check() {
 		--deselect jupyter_core/tests/test_paths.py::test_jupyter_path_user_site \
 		--deselect jupyter_core/tests/test_paths.py::test_jupyter_path_no_user_site \
 		--deselect jupyter_core/tests/test_command.py::test_argv0
-	cd ./docs
 }
 
 package() {
-	python3 setup.py install --prefix=/usr --root="$pkgdir"
+	python3 -m installer -d "$pkgdir" \
+		dist/jupyter_core-$pkgver-py3-none-any.whl
 }
 
 sha512sums="
-0d034a2175fb8b5b5f4ec0be671ecb0b112391c8c66144d9af4adb0166a2fd65bf0ae1d1bd57787b1eaccdc2b8d368540e7c0d6862808cdeaebfd9f8fcb1a496  py3-jupyter_core-4.10.0.tar.gz
+3a2a6b33bd188389bffbcda8c03db5da9a8e330134ae1d63d405387a3b69731857697909a2ab80774a372acd427f8dc043ac48e47f67356d9f217507af11b6b1  py3-jupyter_core-4.11.1.tar.gz
 "
-- 
GitLab