diff --git a/testing/lomiri-weather-app/0001-rename-WEATHER_APP_DIR-to-LOMIRI_WEATHER_APP_DIR.patch b/testing/lomiri-weather-app/0001-rename-WEATHER_APP_DIR-to-LOMIRI_WEATHER_APP_DIR.patch
deleted file mode 100644
index e11cc560c130e4ecf0b93e598618bedb95f23924..0000000000000000000000000000000000000000
--- a/testing/lomiri-weather-app/0001-rename-WEATHER_APP_DIR-to-LOMIRI_WEATHER_APP_DIR.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From d1d9814346b24baffe1850418e0b2f9e172f2bb1 Mon Sep 17 00:00:00 2001
-From: Brandon Boese <brandonboese@protonmail.com>
-Date: Mon, 11 Mar 2024 17:59:17 -0400
-Subject: [PATCH 1/2] rename WEATHER_APP_DIR to LOMIRI_WEATHER_APP_DIR
-
----
- lomiri-weather-app.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lomiri-weather-app.in b/lomiri-weather-app.in
-index 4a179c1..95d7fbc 100644
---- a/lomiri-weather-app.in
-+++ b/lomiri-weather-app.in
-@@ -1,3 +1,3 @@
- #!/bin/bash
- export QT_SELECT=qt5
--exec qmlscene @CMAKE_INSTALL_PREFIX@/@WEATHER_APP_DIR@/@MAIN_QML@
-+exec qmlscene @CMAKE_INSTALL_PREFIX@/@LOMIRI_WEATHER_APP_DIR@/@MAIN_QML@
--- 
-2.43.2
-
diff --git a/testing/lomiri-weather-app/0002-point-qmlscene-to-qmlscene-qt5.patch b/testing/lomiri-weather-app/0002-point-qmlscene-to-qmlscene-qt5.patch
deleted file mode 100644
index 5c4146ed6967e6da5e88757354617070f4f4ba8b..0000000000000000000000000000000000000000
--- a/testing/lomiri-weather-app/0002-point-qmlscene-to-qmlscene-qt5.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 0626f5457f5a5ab00f785b2b68d0b943b99c8ac0 Mon Sep 17 00:00:00 2001
-From: Brandon Boese <brandonboese@protonmail.com>
-Date: Mon, 11 Mar 2024 18:02:26 -0400
-Subject: [PATCH 2/2] point qmlscene to qmlscene-qt5
-
----
- lomiri-weather-app.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lomiri-weather-app.in b/lomiri-weather-app.in
-index 95d7fbc..9fe6475 100644
---- a/lomiri-weather-app.in
-+++ b/lomiri-weather-app.in
-@@ -1,3 +1,3 @@
- #!/bin/bash
- export QT_SELECT=qt5
--exec qmlscene @CMAKE_INSTALL_PREFIX@/@LOMIRI_WEATHER_APP_DIR@/@MAIN_QML@
-+exec qmlscene-qt5 @CMAKE_INSTALL_PREFIX@/@LOMIRI_WEATHER_APP_DIR@/@MAIN_QML@
--- 
-2.43.2
-
diff --git a/testing/lomiri-weather-app/APKBUILD b/testing/lomiri-weather-app/APKBUILD
index 0d4bce9f41d9df4139d823fbd1a13d9549793f88..fdf8e0e84660f851c1fb12909f45823c215e96bb 100644
--- a/testing/lomiri-weather-app/APKBUILD
+++ b/testing/lomiri-weather-app/APKBUILD
@@ -1,31 +1,36 @@
 # Maintainer: Brandon Boese <brandonboese@protonmail.com>
 pkgname=lomiri-weather-app
-pkgver=5.13.5
-pkgrel=1
+pkgver=6.0.2
+pkgrel=0
 pkgdesc="Provides current weather information for your mobile device"
 url="https://gitlab.com/ubports/development/apps/lomiri-weather-app"
 # armhf: blocked by lomiri-ui-toolkit
-# riscv64: blocked by lomiri-indicator-network
-arch="all !armhf !riscv64"
+# ppc64le, riscv64, s390x, loongarch64: blocked by qt5-qtwebengine-dev
+arch="all !armhf !ppc64le !riscv64 !s390x !loongarch64"
 license="GPL-3.0-only"
 source="https://gitlab.com/ubports/development/apps/lomiri-weather-app/-/archive/v$pkgver/lomiri-weather-app-v$pkgver.tar.gz
-	0001-rename-WEATHER_APP_DIR-to-LOMIRI_WEATHER_APP_DIR.patch
-	0002-point-qmlscene-to-qmlscene-qt5.patch
+	desktop-mode.patch
 	"
 depends="
 	lomiri-indicator-network
 	lomiri-ui-extras
 	lomiri-ui-toolkit
+	py3-pyotherside
 	qqc2-suru-style
+	qt5-qtbase-sqlite
 	qt5-qtlocation
 	"
 makedepends="
 	click-dev
 	cmake
 	cmake-extras
+	flatbuffers-dev
 	lomiri-trust-store-dev
 	qt5-qtbase-dev
 	qt5-qtdeclarative-dev
+	qt5-qtlocation-dev
+	qt5-qtquickcontrols2-dev
+	qt5-qtwebengine-dev
 	samurai
 	"
 checkdepends="
@@ -50,13 +55,9 @@ build() {
 
 package() {
 	DESTDIR="$pkgdir" cmake --install build
-
-	mv "$pkgdir"/usr/share/lomiri-weather-app/app/*.svg \
-		"$pkgdir"/usr/share/lomiri-weather-app
 }
 
 sha512sums="
-3a90bd80a8748e9f3a3ab76a36b5e9ba39f9a93999584d7e92e8412170f5c0b7ecb6466b7390420507a572b657a319df4dda6f683f2064e338ee7b21af769261  lomiri-weather-app-v5.13.5.tar.gz
-1755d62aab06d873ba28ddcf5037e13c3faf16bb3b38881ac885caa5a4006f46705a1a25db382e30f8438d8e212e70e2767698ca41ed42d56c64ab86adfbb548  0001-rename-WEATHER_APP_DIR-to-LOMIRI_WEATHER_APP_DIR.patch
-7251565108426e207cdc3ea68c677b4f9b3ba65390d7fac9510704e74985b8b258bd80bf4e25e1fd83fdb92c46228a7ad09a23f0de7b37bcc734fb30ea592628  0002-point-qmlscene-to-qmlscene-qt5.patch
+c6614f62c650a84e3286066daa8e1ae6aaf0cff28d60129f7b569cf3b0e26428f6696ea81404d5d06f5c566b43a8b317dc7c7e9d4f3b3fec3dbcc7d8f83c19f0  lomiri-weather-app-v6.0.2.tar.gz
+271fc27f90a061d2127598e14d2bf969cd995b4e7ce60c0d33c1a0a17a4ff49d6d78c8283b6c535718f8f4c975fc850427274862f30a1767ab215e07727ecb3e  desktop-mode.patch
 "
diff --git a/testing/lomiri-weather-app/desktop-mode.patch b/testing/lomiri-weather-app/desktop-mode.patch
new file mode 100644
index 0000000000000000000000000000000000000000..38377a7e7bb01d1a764bf52a1fea2850e05ee4f9
--- /dev/null
+++ b/testing/lomiri-weather-app/desktop-mode.patch
@@ -0,0 +1,13 @@
+diff --git a/src/app/qml/lomiri-weather-app.qml b/src/app/qml/lomiri-weather-app.qml
+index e204bab..70086f1 100644
+--- a/src/app/qml/lomiri-weather-app.qml
++++ b/src/app/qml/lomiri-weather-app.qml
+@@ -41,7 +41,7 @@ MainView {
+     When the app is started with clickable desktop, the check for network connection via Connectivity does not work.
+     If the app is run in desktop mode, set this property to 'true' and the check will be disabled.
+     */
+-    property bool isDesktopMode: false
++    property bool isDesktopMode: true
+ 
+     automaticOrientation: true
+