diff --git a/testing/perl-json-maybeutf8/APKBUILD b/testing/perl-json-maybeutf8/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..f42008a468abe014bc744222c5784400d20176cb
--- /dev/null
+++ b/testing/perl-json-maybeutf8/APKBUILD
@@ -0,0 +1,39 @@
+# Automatically generated by apkbuild-cpan, template 4
+# Contributor: Celeste <cielesti@protonmail.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
+pkgname=perl-json-maybeutf8
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=JSON-MaybeUTF8
+pkgver=2.000
+pkgrel=0
+pkgdesc="Simple wrapper for explicit JSON Unicode text/UTF-8 byte functions"
+url="https://metacpan.org/release/JSON-MaybeUTF8/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-json-maybexs perl-unicode-utf8"
+checkdepends="perl-test-checkdeps perl-test-deep"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/T/TE/TEAM/JSON-MaybeUTF8-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+	export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+	PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL \
+		INSTALLDIRS=vendor \
+		NO_PACKLIST=1 \
+		NO_PERLLOCAL=1
+	make
+}
+
+check() {
+	export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+	make test
+}
+
+package() {
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+cef0e04695c1f5f6e7e0ba6ec43766d4a46b7457955f13c218207450836eaa06f88cf2596876090584b908c71a40cbce35a82f8cc471891027d5a42a611f2fe6  JSON-MaybeUTF8-2.000.tar.gz
+"