From 09d07263877538c3200e0cb6db32f45a5e93a399 Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Thu, 27 Oct 2022 13:57:56 +0000
Subject: [PATCH] community/gom: disable check

---
 community/gom/APKBUILD | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/community/gom/APKBUILD b/community/gom/APKBUILD
index a0a760f0b441..ad9436e33b42 100644
--- a/community/gom/APKBUILD
+++ b/community/gom/APKBUILD
@@ -12,6 +12,9 @@ makedepends="meson vala gobject-introspection-dev py3-gobject3 sqlite-dev glib-d
 subpackages="$pkgname-dev"
 source="https://download.gnome.org/sources/gom/$pkgver/gom-$pkgver.tar.xz"
 
+# gom-stress seems to segfault with new glib
+options="!check"
+
 build() {
 	abuild-meson . output
 	meson compile ${JOBS:+-j ${JOBS}} -C output
@@ -26,4 +29,6 @@ package() {
 	DESTDIR="$pkgdir" meson install --no-rebuild -C output
 }
 
-sha512sums="d847928ce09c53a3f64777c313cb843052e5e001873f29d3f7acf02772cadf0e4b133fb0137aa0463b4ff95dd54810bde87062d8e396ff4fc6d142ba59c8e9c8  gom-0.4.tar.xz"
+sha512sums="
+d847928ce09c53a3f64777c313cb843052e5e001873f29d3f7acf02772cadf0e4b133fb0137aa0463b4ff95dd54810bde87062d8e396ff4fc6d142ba59c8e9c8  gom-0.4.tar.xz
+"
-- 
GitLab