From 089ebc95b97a565a0ae760a62f181b8939c5e32f Mon Sep 17 00:00:00 2001
From: psykose <alice@ayaya.dev>
Date: Fri, 14 Oct 2022 13:21:34 +0000
Subject: [PATCH] testing/htmlcxx: fix build with gcc12

---
 testing/htmlcxx/APKBUILD | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/testing/htmlcxx/APKBUILD b/testing/htmlcxx/APKBUILD
index e9be54150686..77b8f5278f9e 100644
--- a/testing/htmlcxx/APKBUILD
+++ b/testing/htmlcxx/APKBUILD
@@ -12,7 +12,12 @@ subpackages="$pkgname-dev"
 source="$pkgname-$pkgver.tar.gz::https://sourceforge.net/projects/htmlcxx/files/v$pkgver/htmlcxx-$pkgver.tar.gz"
 
 build() {
-	./configure --prefix=/usr --build=$CBUILD --host=$CHOST
+	# gcc12 defaults to 17 which fails due to throw()
+	export CXXFLAGS="$CXXFLAGS -std=c++14"
+	./configure \
+		--prefix=/usr \
+		--build=$CBUILD \
+		--host=$CHOST
 	make
 }
 
-- 
GitLab