diff --git a/community/acf-vlc-daemon/APKBUILD b/community/acf-vlc-daemon/APKBUILD
index 0ca38b5095887857c9f330a3d8084422f9f1ebdc..36189bf0db282791c746dff8540f74f88722d797 100644
--- a/community/acf-vlc-daemon/APKBUILD
+++ b/community/acf-vlc-daemon/APKBUILD
@@ -2,35 +2,16 @@
 # Maintainer:
 pkgname=acf-vlc-daemon
 pkgver=0.5.0
-pkgrel=2
-pkgdesc="A web-based system administration interface for vlc"
+pkgrel=3
+pkgdesc="Web-based system administration interface for vlc"
 url="https://git.alpinelinux.org/cgit/acf/acf-vlc-daemon"
 arch="noarch !s390x !mips !mips64"
-license="GPL-2.0"
+license="GPL-2.0-only"
 depends="acf-core vlc-daemon"
-depends_dev=""
 makedepends="$depends_dev"
-install=""
-subpackages=""
-source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
-	local i
-	cd "$_builddir"
-	for i in $source; do
-		case $i in
-		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
-		esac
-	done
-}
-
-build() {
-	return 0
-}
+source="https://dev.alpinelinux.org/archive/acf-vlc-daemon/acf-vlc-daemon-$pkgver.tar.xz"
 
 package() {
-	cd "$_builddir"
 	make DESTDIR="$pkgdir" install
 }