diff --git a/testing/btcd/APKBUILD b/testing/btcd/APKBUILD
index 378cad48e1e12bf0c98aa2434c1baa4dac17e10a..01911f26a67fd327a1c4d4a5725d2dbdd186ad83 100644
--- a/testing/btcd/APKBUILD
+++ b/testing/btcd/APKBUILD
@@ -8,7 +8,9 @@ url="https://github.com/btcsuite/btcd#btcd"
 arch="all"
 license="ISC"
 makedepends="go"
-source="https://github.com/btcsuite/btcd/archive/v$_pkgver/$pkgname-$_pkgver.tar.gz"
+source="https://github.com/btcsuite/btcd/archive/v$_pkgver/btcd-$_pkgver.tar.gz
+	fix-test.patch
+	"
 builddir="$srcdir/$pkgname-$_pkgver"
 
 build() {
@@ -27,4 +29,5 @@ package() {
 }
 sha512sums="
 cae1bf46900890e4bc01b817f72cbf6654636af5bac887032a85afba91a813162e5b2e1bcb23cd0a013e8b0711d9e7a68d6ff08f8767c6b375a2df7d8d72c291  btcd-0.22.0-beta.tar.gz
+ba6a8a79ca5c4419c4983042f9c49548ff3548b1002705ae106c2123424bc492a477e9693334fb5264ebe38f01cac6a9b36c8fe392cec0f4257ac5e78534578e  fix-test.patch
 "
diff --git a/testing/btcd/fix-test.patch b/testing/btcd/fix-test.patch
new file mode 100644
index 0000000000000000000000000000000000000000..1132fd2df3f54fc84161e3a1ec545266b322b133
--- /dev/null
+++ b/testing/btcd/fix-test.patch
@@ -0,0 +1,11 @@
+--- a/mempool/mempool_test.go
++++ b/mempool/mempool_test.go
+@@ -560,7 +560,7 @@
+ 
+ 		// Ensure no transactions were reported as accepted.
+ 		if len(acceptedTxns) != 0 {
+-			t.Fatal("ProcessTransaction: reported %d accepted "+
++			t.Fatalf("ProcessTransaction: reported %d accepted "+
+ 				"transactions from failed orphan attempt",
+ 				len(acceptedTxns))
+ 		}