diff --git a/community/libtraceevent/APKBUILD b/community/libtraceevent/APKBUILD
index f780b3d0251e851590fb0ece99b0cccaa79c6b00..54131ab90b561051094b04209abeba09ba249be7 100644
--- a/community/libtraceevent/APKBUILD
+++ b/community/libtraceevent/APKBUILD
@@ -1,33 +1,36 @@
 # Maintainer: psykose <alice@ayaya.dev>
 pkgname=libtraceevent
-pkgver=1.7.2
+pkgver=1.7.3
 pkgrel=0
 pkgdesc="Linux kernel trace event library"
 url="https://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git"
 arch="all"
 license="LGPL-2.1-or-later AND GPL-2.0-or-later"
 depends_dev="linux-headers"
-makedepends="$depends_dev"
+makedepends="
+	$depends_dev
+	asciidoc
+	meson
+	xmlto
+	"
 checkdepends="cunit-dev"
 subpackages="$pkgname-plugins $pkgname-dev"
 source="https://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git/snapshot/libtraceevent-$pkgver.tar.gz"
 
 build() {
-	make
+	abuild-meson \
+		--default-library=shared \
+		-Db_lto=true \
+		. output
+	meson compile -C output
 }
 
 check() {
-	make test
+	meson test --no-rebuild --print-errorlogs -C output
 }
 
 package() {
-	make \
-		pkgconfig_dir=/usr/lib/pkgconfig \
-		prefix=/usr \
-		libdir_relative=lib \
-		DESTDIR="$pkgdir" \
-		install
-	rm -v "$pkgdir"/usr/lib/*.a
+	DESTDIR="$pkgdir" meson install --no-rebuild -C output
 }
 
 plugins() {
@@ -35,9 +38,9 @@ plugins() {
 	# it had the same plugin files
 	replaces="perf<6.2"
 
-	amove usr/lib/traceevent/plugins
+	amove usr/lib/libtraceevent/plugins
 }
 
 sha512sums="
-aa6d14e6d2e8e64c7d53ba9f93d47331d5f1b5a5a624891ec18a08b0d4e3e82f7845d29957bb3fe4360151bb5870a67c69d5cb1f758bb2956d946221f186546e  libtraceevent-1.7.2.tar.gz
+81302cb24a3fc71e8bd6a0ba975a2699eaa629ac0e90837bf8fc8e23e04156827d19b25544cdb506b0bf76d5f08699264c9ecb979f9218bdee6b0b0e7339b1e0  libtraceevent-1.7.3.tar.gz
 "