diff --git a/testing/fast_float/APKBUILD b/testing/fast_float/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..d432a11897fdc9a813658d0895c492240d1331fd
--- /dev/null
+++ b/testing/fast_float/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Grigory Kirillov <txgk@bk.ru>
+# Maintainer: Grigory Kirillov <txgk@bk.ru>
+pkgname=fast_float
+pkgver=3.4.0
+pkgrel=0
+pkgdesc="Fast implementation of the C++ from_chars functions for float and double types"
+url="https://github.com/fastfloat/fast_float"
+arch="noarch"
+license="Apache-2.0 OR MIT"
+makedepends="cmake samurai"
+checkdepends="doctest-dev"
+source="https://github.com/fastfloat/fast_float/archive/v$pkgver/fast_float-$pkgver.tar.gz"
+
+build() {
+	cmake -B builddir -G Ninja \
+		-DCMAKE_INSTALL_PREFIX=/usr \
+		-DCMAKE_BUILD_TYPE=Release \
+		-DFASTFLOAT_TEST=ON \
+		-DSYSTEM_DOCTEST=ON
+	cmake --build builddir
+}
+
+check() {
+	ctest --output-on-failure --test-dir builddir
+}
+
+package() {
+	DESTDIR="$pkgdir" cmake --install builddir
+	install -dm 644 "$pkgdir"/usr/lib/cmake
+	mv "$pkgdir"/usr/share/FastFloat "$pkgdir"/usr/lib/cmake/.
+}
+
+sha512sums="
+6adf278eca5be16c1fbf9ba04edba71fff4af92fca37ca5f3ea8fcd5f31497b7f8f4654c500a4ef6e521053b4125409d34f484a2dd5b45399b49be9c143270a1  fast_float-3.4.0.tar.gz
+"