diff --git a/community/hydrogen/0001-rtclock-fix-implicit-sleep-declaration.patch b/community/hydrogen/0001-rtclock-fix-implicit-sleep-declaration.patch
deleted file mode 100644
index e8852601a21fd8e8c1feee375f297a3ed3c18359..0000000000000000000000000000000000000000
--- a/community/hydrogen/0001-rtclock-fix-implicit-sleep-declaration.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From f1aef07dbac734640dae28e99512e5e3f4b9a957 Mon Sep 17 00:00:00 2001
-From: psykose <alice@ayaya.dev>
-Date: Sun, 5 Feb 2023 13:01:50 +0000
-Subject: [PATCH] rtclock: fix implicit sleep declaration
-
-otherwise clang16 fails to compile this code, and detects this as false
----
- cmake/rtclock/rtclock.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/cmake/rtclock/rtclock.c b/cmake/rtclock/rtclock.c
-index 851e78dc..439be41f 100644
---- a/cmake/rtclock/rtclock.c
-+++ b/cmake/rtclock/rtclock.c
-@@ -1,6 +1,7 @@
- #include <stdio.h>
- #include <time.h>
- #include <stdint.h>
-+#include <unistd.h>
- int main( int argc, char** argv, char** env ) {
-     uint64_t dt;
-     struct timespec t0,t1;
--- 
-2.39.1
-
diff --git a/community/hydrogen/APKBUILD b/community/hydrogen/APKBUILD
index 75f82af35fc3c2b40abb3a50bee03b1e15bf6966..e9188a66ac5d1bceb17429f52cf33cc6e607de36 100644
--- a/community/hydrogen/APKBUILD
+++ b/community/hydrogen/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Natanael Copa <ncopa@alpinelinux.org>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=hydrogen
-pkgver=1.1.1
-pkgrel=1
+pkgver=1.2.0
+pkgrel=0
 pkgdesc="Advanced drum machine for GNU/Linux"
 url="http://www.hydrogen-music.org/"
 arch="aarch64 armv7 ppc64le x86 x86_64" # armhf limited by qt5-qtxmlpatterns
@@ -18,6 +18,7 @@ makedepends="
 	portaudio-dev
 	pulseaudio-dev
 	qt5-qtbase-dev
+	qt5-qtsvg-dev
 	qt5-qttools-dev
 	qt5-qtxmlpatterns-dev
 	samurai
@@ -25,8 +26,8 @@ makedepends="
 checkdepends="cppunit-dev"
 subpackages="$pkgname-dev $pkgname-doc"
 source="hydrogen-$pkgver.tar.gz::https://github.com/hydrogen-music/hydrogen/archive/$pkgver.tar.gz
-	0001-rtclock-fix-implicit-sleep-declaration.patch
 	nodevel.patch
+	timeval.patch
 	"
 # tiny float differences
 options="!check"
@@ -56,7 +57,7 @@ package() {
 }
 
 sha512sums="
-c5e6bd713a0f9ef3b30bf0ae00bc41fea7494c20342c14c9f41ec05d1fdd3be721ffc3ff92bacd011e3b39a68022ea04daf55e60d334f64a00abef17d892cd37  hydrogen-1.1.1.tar.gz
-6cce04b14b862c0ffc057f9e15a32ef0acece984eca91ce06ebb6bee42b66eb60dfe83ea1673e749fdf70b0983931299fcdc9d98fe5ab68cd9e4f45ff904d4fa  0001-rtclock-fix-implicit-sleep-declaration.patch
+610dc292ab26880897030ee7e969caf11e2758e0cccdc15b21711a2114564e12af855b50f0cf13964689b6697255c5f2080e2114c916ea6fbe3909057e7de1df  hydrogen-1.2.0.tar.gz
 9135b7c4ec4818df3e28f9dfcc3d8a88f407ffd0a74ebc8ad0a29f91d514d667db93f03cc4f7cfaa65e4034c6f2270ec574ad32d79679e8b012a6f0c1bf13f7c  nodevel.patch
+4bb2a64f4aca52fd961a564620bac6d822e92cfbaa2802a49ec7f15edb63aa77fecd29c2bb1ebbf90626f83d74ee9bf1b1e2868a133ed2a93ebd4e811868793e  timeval.patch
 "
diff --git a/community/hydrogen/timeval.patch b/community/hydrogen/timeval.patch
new file mode 100644
index 0000000000000000000000000000000000000000..b302d6e4e47d224b84e109766665d9530e88c687
--- /dev/null
+++ b/community/hydrogen/timeval.patch
@@ -0,0 +1,12 @@
+diff --git a/src/core/Object.h b/src/core/Object.h
+index 4ab6660..7aa2c8a 100644
+--- a/src/core/Object.h
++++ b/src/core/Object.h
+@@ -30,6 +30,7 @@
+ #include <unistd.h>
+ #include <iostream>
+ #include <atomic>
++#include <sys/time.h>
+ #include <map>
+ #include <QtCore>
+ #include <QDebug>