diff --git a/community/weston/APKBUILD b/community/weston/APKBUILD
index e1883c3d271f3c3a835956c73f0aa0c77df90264..ec309736927c159400b03b962945a774e9603625 100644
--- a/community/weston/APKBUILD
+++ b/community/weston/APKBUILD
@@ -2,20 +2,19 @@
 # Maintainer: Valery Kartel <valery.kartel@gmail.com>
 pkgname=weston
 pkgver=10.0.1
-pkgrel=0
+pkgrel=1
 _libname=lib$pkgname
 _libdir=$_libname-${pkgver%%.*}
 pkgdesc="The reference Wayland server"
 url="https://wayland.freedesktop.org/"
-# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !ppc64le !riscv64"
+arch="all"
 license="MIT"
 makedepends="wayland-protocols libxkbcommon-dev xkeyboard-config
 	libinput-dev libunwind-dev mtdev-dev libxcursor-dev glu-dev
 	pango-dev colord-dev libwebp-dev libva-dev dbus-dev
 	linux-pam-dev wayland-dev libevdev-dev libjpeg-turbo-dev
 	freerdp-dev lcms2-dev gstreamer-dev gst-plugins-base-dev meson
-	elogind-dev
+	elogind-dev pipewire-dev
 	"
 _cms="cms-colord cms-static"
 _shell="shell-desktop shell-fullscreen shell-ivi"
@@ -31,15 +30,20 @@ subpackages="$pkgname-dev $pkgname-doc $subpackages
 	$pkgname-xwayland $pkgname-desktop-x11:_x11:noarch
 	"
 source="https://gitlab.freedesktop.org/wayland/weston/-/releases/$pkgver/downloads/weston-$pkgver.tar.xz"
-# weston-launch requires suid
-options="!check suid"
+options="!check"
 install="$pkgname.pre-install"
 
+prepare() {
+	default_prepare
+
+	# dodge git version
+	git init .
+}
+
 build() {
 	abuild-meson \
 		-Dlauncher-logind=true \
 		-Dsystemd=false \
-		-Dpipewire=false \
 		build
 	meson compile ${JOBS:+-j ${JOBS}} -C build
 }
@@ -47,11 +51,11 @@ build() {
 # Does not run through, see also:
 # https://github.com/alpinelinux/aports/pull/1689
 check() {
-	ninja -C "$builddir"/build test
+	meson test -v --no-rebuild -C build
 }
 
 package() {
-	DESTDIR="$pkgdir" ninja -C "$builddir"/build install
+	DESTDIR="$pkgdir" meson install --no-rebuild -C build
 
 	mkdir -p "$pkgdir"/usr/lib
 	mv "$pkgdir"/usr/share/pkgconfig/* "$pkgdir"/usr/lib/pkgconfig/