diff --git a/testing/timg/APKBUILD b/testing/timg/APKBUILD
index f89fa30ed4f3e1bcd256b2b0b4742e09a8873527..1f8e73ade452de1ed449d0f587e83640f94e48a8 100644
--- a/testing/timg/APKBUILD
+++ b/testing/timg/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Milan P. Stanić <mps@arvanta.net>
 # Maintainer: Milan P. Stanić <mps@arvanta.net>
 pkgname=timg
-pkgver=0.9.5
+pkgver=0.9.8
 pkgrel=0
 pkgdesc="24-Bit color image viewer for terminal"
 url="https://github.com/hzeller/timg"
@@ -9,21 +9,15 @@ arch="all"
 options="!check" # package doesn't have test
 license="GPL-2.0-only"
 makedepends="libwebp-dev graphicsmagick-dev freetype-dev xz-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hzeller/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hzeller/timg/archive/v$pkgver.tar.gz"
 builddir="$srcdir/$pkgname-$pkgver"/src
 
 build() {
-	cd "$builddir"
 	make
 }
 
-check() {
-	cd "$builddir"
-}
-
 package() {
-	cd "$builddir"
 	install -Dm755 timg "$pkgdir"/usr/bin/timg
 }
 
-sha512sums="993bdaf80f05fa7e7961d6f4fc5847313a679934750e0b38c78d3f3ad9ebe54d9b67b580a085734626ae43da58b33f2b2a0dcba203e00235095be667a4c01657  timg-0.9.5.tar.gz"
+sha512sums="b9d1bec542d3e2620baece1d90d33af00de0af8c4544aecf109ce9ea42138ad6693a6683cb39cfa4acbd3aad45d3773f47a8c715c85c57ad983327259bc615d7  timg-0.9.8.tar.gz"