diff --git a/community/afl++/APKBUILD b/community/afl++/APKBUILD
index ba97595ab1fd7231089635cd327b47900d1e28ad..2c86cf2aa4323c1a8a070883e534904e441ae346 100644
--- a/community/afl++/APKBUILD
+++ b/community/afl++/APKBUILD
@@ -1,8 +1,8 @@
 # Contributor: Marian <marian.buschsieweke@posteo.net>
 # Maintainer: Marian <marian.buschsieweke@posteo.net>
 pkgname=afl++
-pkgver=4.21c
-pkgrel=2
+pkgver=4.30c
+pkgrel=0
 pkgdesc="Fuzzer relying on genetic algorithms instead of brute force"
 url="https://aflplus.plus/"
 # x86: test failures
@@ -47,6 +47,8 @@ provides="
 	"
 source="
 	$pkgname-$pkgver.tar.gz::https://github.com/AFLplusplus/AFLplusplus/archive/refs/tags/v$pkgver.tar.gz
+
+	f2f417325f25de83bb149c178d36e00631e3d4bb.patch
 	"
 builddir="$srcdir/AFLplusplus-$pkgver"
 
@@ -91,5 +93,6 @@ tools() {
 }
 
 sha512sums="
-cb58d58561ac814e07e9b5b735fade42b977fb1b92a63f1d7a66a5809203e83acf805ccfdc8ce29c9a3b374a189690010ca3d8ae20e261680751cea3c4841777  afl++-4.21c.tar.gz
+072c9524978843eec6be5428793be43d10f3530a3f569fd4015d950cdd87696e887c3b567440afee8cb5e359b234d0c5e668cf9ab90622783fc82f68e3ec5f98  afl++-4.30c.tar.gz
+d0c2cc3ca8fb51ede36f58078bbfe6e2d95c3084857680cce404586b9a796322b7bb07b207cef630da494bbf8bac9c228d8f3998921aa6cbe0e24f87e438afcd  f2f417325f25de83bb149c178d36e00631e3d4bb.patch
 "
diff --git a/community/afl++/f2f417325f25de83bb149c178d36e00631e3d4bb.patch b/community/afl++/f2f417325f25de83bb149c178d36e00631e3d4bb.patch
new file mode 100644
index 0000000000000000000000000000000000000000..dc73d1258df67be6e0b5a7c0240f249186376c54
--- /dev/null
+++ b/community/afl++/f2f417325f25de83bb149c178d36e00631e3d4bb.patch
@@ -0,0 +1,22 @@
+From f2f417325f25de83bb149c178d36e00631e3d4bb Mon Sep 17 00:00:00 2001
+From: vanhauser-thc <vh@thc.org>
+Date: Sun, 15 Dec 2024 18:06:02 +0100
+Subject: [PATCH] fix gcc plugin test
+
+---
+ test/test-gcc-plugin.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/test-gcc-plugin.sh b/test/test-gcc-plugin.sh
+index 04da5d9ce..6f32c8e01 100755
+--- a/test/test-gcc-plugin.sh
++++ b/test/test-gcc-plugin.sh
+@@ -81,7 +81,7 @@ test -e ../afl-gcc-fast -a -e ../afl-compiler-rt.o && {
+ 
+   # now for the special gcc_plugin things
+   echo foobar.c > instrumentlist.txt
+-  AFL_COMPILER_INSTRUMENT_FILE=instrumentlist.txt ../afl-gcc-fast -o test-compcov test-compcov.c > /dev/null 2>&1
++  AFL_GCC_INSTRUMENT_FILE=instrumentlist.txt ../afl-gcc-fast -o test-compcov test-compcov.c > /dev/null 2>&1
+   test -x test-compcov && test_compcov_binary_functionality ./test-compcov && {
+     echo 1 | AFL_QUIET=1 ../afl-showmap -m ${MEM_LIMIT} -o - -r -- ./test-compcov 2>&1 | grep -q "Captured 0 tuples" && {
+       $ECHO "$GREEN[+] gcc_plugin instrumentlist feature works correctly"