Commit 9154b8b5 authored by Natanael Copa's avatar Natanael Copa

ver: print '?' when package is not available in any repo

This makes it possible to differ between downgradable packages (-l '<')
and unavailable in repos (-l '?').
parent c9a43a14
......@@ -14,6 +14,7 @@
#include "apk_blob.h"
#define APK_VERSION_UNKNOWN 0
#define APK_VERSION_EQUAL 1
#define APK_VERSION_LESS 2
#define APK_VERSION_GREATER 4
......
......@@ -125,7 +125,8 @@ static void ver_print_package_status(struct ver_ctx *ictx, struct apk_database *
break;
}
}
r = apk_version_compare_blob(*pkg->version, *latest);
r = latest->len ? apk_version_compare_blob(*pkg->version, *latest)
: APK_VERSION_UNKNOWN;
opstr = apk_version_op_string(r);
if ((ictx->limchars != NULL) && (strchr(ictx->limchars, *opstr) == NULL))
return;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment