1. 19 Jun, 2013 1 commit
    • Timo Teräs's avatar
      upgrade: new option: --latest (-l) · d315c901
      Timo Teräs authored
      Select latest version of package (if it is not pinned), and print
      error if it cannot be installed due to other dependencies.
      
      Together with --available, it selects the latest package which is
      present at least in some repository.
      
      This also fixes few solver issues with ordering of package selection
      that got quite apparent with this flag. Namely, we cannot "lock"
      a package until it's reverse dependencies are locked or not all of
      the solver flags are propagated properly.
      d315c901