Commit 8a794021 authored by Timo Teräs's avatar Timo Teräs

commit: rephrase the error messages more understandable

fixes #10703
parent c269e9c2
Pipeline #51303 passed with stage
in 41 seconds
......@@ -540,7 +540,7 @@ static void analyze_name(struct print_state *ps, struct apk_name *name)
}
label_end(ps);
} else {
snprintf(tmp, sizeof(tmp), "%s (missing)", name->name);
snprintf(tmp, sizeof(tmp), "%s (no such package)", name->name);
ps->label = tmp;
}
......@@ -637,7 +637,7 @@ void apk_solver_print_errors(struct apk_database *db,
* any other selected version. or all of them with -v.
*/
apk_error("unsatisfiable constraints:");
apk_error("unable to select packages:");
/* Construct information about names */
foreach_array_item(change, changeset->changes) {
......
......@@ -6,7 +6,7 @@
--latest
upgrade
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
b-2:
masked in: --no-network
satisfies: a-2[b]
......
......@@ -5,6 +5,6 @@
--latest
upgrade
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
a-2:
breaks: world[a<2]
......@@ -2,7 +2,7 @@
--test-repo conflict.repo
add a b>1
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
b-2:
breaks: a-1[!b>1]
satisfies: world[b>1]
......@@ -2,7 +2,7 @@
--test-repo complicated1.repo
add a d>1.5
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
d-2.0:
breaks: b-1[d<2.0]
satisfies: world[d>1.5] a-3[d>1.5] c-1[d>1.0]
......@@ -2,7 +2,7 @@
--test-repo complicated1.repo
add a d<1.5
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
d-1.0:
breaks: c-1[d>1.0]
satisfies: world[d<1.5] b-1[d<2.0]
......@@ -2,7 +2,7 @@
--test-repo complicated1.repo
add a !b
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
d-2.0:
breaks: b-1[d<2.0]
satisfies: a-3[d>1.5] c-1[d>1.0]
......
......@@ -2,6 +2,6 @@
--test-repo complicated1.repo
add a nonexistant
@EXPECT
ERROR: unsatisfiable constraints:
nonexistant (missing):
ERROR: unable to select packages:
nonexistant (no such package):
required by: world[nonexistant]
......@@ -2,7 +2,7 @@
--test-repo complicated1.repo
add a>2
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
d-2.0:
breaks: b-1[d<2.0]
satisfies: a-3[d>1.5] c-1[d>1.0]
......@@ -4,7 +4,7 @@
--test-world "a@testing"
add c>=3
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
c-3:
masked in: @testing
satisfies: world[c>=3]
......@@ -3,7 +3,7 @@
--test-repo provides.repo
add conflicted-dep
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
conflicted-provider (virtual):
provided by: conflicted-provider-a
conflicted-provider-b
......
......@@ -3,7 +3,7 @@
--test-repo provides.repo
add conflicted-parent
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
conflicted-provider (virtual):
provided by: conflicted-provider-a
conflicted-provider-b
......
......@@ -2,7 +2,7 @@
--test-repo provides.repo
add self-provide
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
self-provide-0.1:
conflicts: self-provide-0.1[self-provide]
satisfies: world[self-provide]
......@@ -2,7 +2,7 @@
--test-repo provides.repo
add server-a server-b
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
server-a-1:
conflicts: server-b-1[theservice=1]
satisfies: world[server-a]
......
......@@ -2,7 +2,7 @@
--test-repo provides.repo
add app app2
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
libfoo-1:
conflicts: libfoo-2
satisfies: app-2[so:foo.so.1]
......
......@@ -2,7 +2,7 @@
--test-repo provides.repo
add selfconflicting
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
selfconflicting-1:
conflicts: selfconflicting-1[selfprovided=2]
selfconflicting-1[selfprovided=3]
......
......@@ -2,7 +2,7 @@
--test-repo provides.repo
add conflicted-provider
@EXPECT
ERROR: unsatisfiable constraints:
ERROR: unable to select packages:
conflicted-provider (virtual):
provided by: conflicted-provider-a
conflicted-provider-b
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment