Commit 67181962 authored by Natanael Copa's avatar Natanael Copa

apkbuild-cpan: include modules that used to be part of core

we need to check if a given module currently is a part of core. Modules
which have a first_release may have been removed later, for example
Module::Build.
parent 122bcd7c
......@@ -125,7 +125,8 @@ sub parse_deps {
my $deps = "";
for my $module ($reqs->required_modules) {
if (my $perlver = Module::CoreList->first_release($module)) {
if (Module::CoreList->is_core($module)) {
my $perlver = Module::CoreList->first_release($module);
say "$module is part of core perl since $perlver.";
next;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment