Commit c85fc5b5 authored by Kaarle Ritvanen's avatar Kaarle Ritvanen

apkbuild-gem-resolver: support ruby 2.2.4

parent c2c64104
#!/usr/bin/ruby #!/usr/bin/ruby
# APKBUILD dependency resolver for RubyGems # APKBUILD dependency resolver for RubyGems
# Copyright (C) 2014-2015 Kaarle Ritvanen # Copyright (C) 2014-2016 Kaarle Ritvanen
require 'augeas' require 'augeas'
require 'optparse' require 'optparse'
...@@ -172,6 +172,14 @@ class Subpackage < Package ...@@ -172,6 +172,14 @@ class Subpackage < Package
'ruby-minitest' => ['minitest', '5.4.3'], 'ruby-minitest' => ['minitest', '5.4.3'],
'ruby-rake' => ['rake', '10.4.2'], 'ruby-rake' => ['rake', '10.4.2'],
'ruby-rdoc' => ['rdoc', '4.2.0', 'ruby-json'] 'ruby-rdoc' => ['rdoc', '4.2.0', 'ruby-json']
},
'2.2.4' => {
# it's actually 0.4.3 but that version is not published on network
'ruby-io-console' => ['io-console', '0.4.2'],
'ruby-json' => ['json', '1.8.1'],
'ruby-minitest' => ['minitest', '5.4.3'],
'ruby-rake' => ['rake', '10.4.2'],
'ruby-rdoc' => ['rdoc', '4.2.0', 'ruby-json']
} }
} }
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment