Commit b7c197f2 authored by Łukasz Jendrysik's avatar Łukasz Jendrysik Committed by Natanael Copa

Removed conflicts= support

Conflicts support in an abuild seems to be uneccessary feature.
Signed-off-by: Łukasz Jendrysik's avatarŁukasz Jendrysik <scadu@yandex.com>
parent fa204f85
...@@ -824,9 +824,6 @@ EOF ...@@ -824,9 +824,6 @@ EOF
for i in $deps; do for i in $deps; do
echo "depend = $i" >> "$pkginfo" echo "depend = $i" >> "$pkginfo"
done done
for i in $conflicts; do
echo "conflict = $i" >> "$pkginfo"
done
for i in $provides; do for i in $provides; do
echo "provides = $i" >> "$pkginfo" echo "provides = $i" >> "$pkginfo"
done done
...@@ -1531,7 +1528,7 @@ deptrace() { ...@@ -1531,7 +1528,7 @@ deptrace() {
# build and install dependencies # build and install dependencies
builddeps() { builddeps() {
local pkg= i= missing= conflicts= local pkg= i= missing=
local hostdeps= builddeps= installed_hostdeps= installed_builddeps= local hostdeps= builddeps= installed_hostdeps= installed_builddeps=
[ -n "$nodeps" ] && return 0 [ -n "$nodeps" ] && return 0
msg "Analyzing dependencies..." msg "Analyzing dependencies..."
...@@ -1562,26 +1559,19 @@ builddeps() { ...@@ -1562,26 +1559,19 @@ builddeps() {
# find which deps are missing # find which deps are missing
for i in $builddeps; do for i in $builddeps; do
if [ "${i#\!}" != "$i" ]; then if [ "${i#\!}" != "$i" ]; then
$APK info --quiet --installed "${i#\!}" \ $APK info --quiet --installed "${i#\!}"
&& conflicts="$conflicts ${i#\!}"
elif ! deplist_has $i $installed_builddeps || [ -n "$upgrade" ]; then elif ! deplist_has $i $installed_builddeps || [ -n "$upgrade" ]; then
missing="$missing $i" missing="$missing $i"
fi fi
done done
for i in $hostdeps; do for i in $hostdeps; do
if [ "${i#\!}" != "$i" ]; then if [ "${i#\!}" != "$i" ]; then
$APK info --quiet --installed --root "$CBUILDROOT" "${i#\!}" \ $APK info --quiet --installed --root "$CBUILDROOT" "${i#\!}"
&& conflicts="$conflicts ${i#\!}"
elif ! deplist_has $i $installed_hostdeps || [ -n "$upgrade" ]; then elif ! deplist_has $i $installed_hostdeps || [ -n "$upgrade" ]; then
missing="$missing $i" missing="$missing $i"
fi fi
done done
if [ -n "$conflicts" ]; then
error "Conflicting package(s) installed:$conflicts"
return 1
fi
if [ -z "$install_deps" ] && [ -z "$recursive" ]; then if [ -z "$install_deps" ] && [ -z "$recursive" ]; then
# if we dont have any missing deps we are done now # if we dont have any missing deps we are done now
[ -z "$missing" ] && return 0 [ -z "$missing" ] && return 0
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment