diff --git a/main/libbytesize/APKBUILD b/main/libbytesize/APKBUILD
index 8b96751aaa0fb7e548af6474f788e7b930fb6142..51ac5c2b227aefbef7f0dd125ca7230c50e03b55 100644
--- a/main/libbytesize/APKBUILD
+++ b/main/libbytesize/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: André Klitzing <aklitzing@gmail.com>
 pkgname=libbytesize
 pkgver=2.1
-pkgrel=0
+pkgrel=1
 pkgdesc="Library for working with arbitrary big sizes in bytes"
 options="!check" # Tests require dealing with locales
 url="https://github.com/rhinstaller/libbytesize"
@@ -13,7 +13,7 @@ makedepends="gettext-dev gmp-dev mpfr-dev pcre2-dev python3"
 checkdepends="bash py3-six"
 subpackages="$pkgname-dev $pkgname-lang py-$pkgname:_py:noarch $pkgname-doc
  $pkgname-tools:_tools:noarch"
-source="https://github.com/storaged-project/libbytesize/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/storaged-project/libbytesize/releases/download/$pkgver/libbytesize-$pkgver.tar.gz"
 
 build() {
 	CFLAGS="$CFLAGS -lintl" ./configure --prefix=/usr