diff --git a/community/llvm3.7/APKBUILD b/community/llvm3.7/APKBUILD
index a3e0bb8ed81347696dcc128b1b27ab60ffb32ded..ae6019d2af2a2d1c60150d7e8daa839692a91170 100644
--- a/community/llvm3.7/APKBUILD
+++ b/community/llvm3.7/APKBUILD
@@ -25,6 +25,12 @@ source="http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz
 	"
 builddir="$srcdir/$_pkgname-$pkgver.src"
 
+# ARM has few failures in test suite that we don't care about currently and
+# also it takes forever to run them on the builder.
+case "$CARCH" in
+	arm*) options="!check";;
+esac
+
 # NOTE: It seems that there's no (sane) way how to change includedir, sharedir
 # etc. separately, just the CMAKE_INSTALL_PREFIX. Standard CMake variables and
 # even  LLVM-specific variables, that are related to these paths, actually
@@ -106,11 +112,7 @@ build() {
 check() {
 	cd "$builddir"/build
 
-	# ARM has few failures in test suite that we don't care about currently.
-	case "$CARCH" in
-		arm*) make check-llvm || true;;
-		*) make check-llvm;;
-	esac
+	make check-llvm
 }
 
 package() {