From cfb425ec4617e8993d0ab54865b50d7499a4cbbe Mon Sep 17 00:00:00 2001
From: Francesco Colista <fcolista@alpinelinux.org>
Date: Wed, 23 Nov 2016 08:27:22 +0000
Subject: [PATCH] community/perl-tie-has-method: new aport. In community
 because of per-test-postgresql dependency

---
 community/perl-tie-hash-method/APKBUILD | 42 +++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
 create mode 100644 community/perl-tie-hash-method/APKBUILD

diff --git a/community/perl-tie-hash-method/APKBUILD b/community/perl-tie-hash-method/APKBUILD
new file mode 100644
index 000000000000..a263ac54acf0
--- /dev/null
+++ b/community/perl-tie-hash-method/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-tie-hash-method
+_pkgreal=Tie-Hash-Method
+pkgver=0.02
+pkgrel=0
+pkgdesc="Tied hash with specific methods overriden by callbacks"
+url="http://search.cpan.org/dist/Tie-Hash-Method/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="   "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/Y/YV/YVES/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+	default_prepare || return 1
+
+	cd "$builddir"
+	export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+	PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+	cd "$builddir"
+	export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+	make && make test
+}
+
+package() {
+	cd "$builddir"
+	make DESTDIR="$pkgdir" install || return 1
+	find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="d7ca97ed34a31ae9dc90f666be5f1151  Tie-Hash-Method-0.02.tar.gz"
+sha256sums="d513fbb51413f7ca1e64a1bdce6194df7ec6076dea55066d67b950191eec32a9  Tie-Hash-Method-0.02.tar.gz"
+sha512sums="e32e911310dfbe066167a8750f9e9a4c5b277c4666addaf3a6b00851ef47e190c88195c394b8778b38e570001ada38f00d78b2ca4fa32498bf8fbb1f94b82424  Tie-Hash-Method-0.02.tar.gz"
-- 
GitLab