diff --git a/testing/nut/APKBUILD b/testing/nut/APKBUILD
index e20c94b830cc84a1fa8f9c606651b4c56a6b094d..222d4ccad7c7d94b22ba86ea850c4524d389bd95 100644
--- a/testing/nut/APKBUILD
+++ b/testing/nut/APKBUILD
@@ -1,7 +1,7 @@
 # Contributor: Kozak Ivan <kozak-iv@yandex.ru>
 # Maintainer: Kozak Ivan <kozak-iv@yandex.ru>
 pkgname=nut
-pkgver=2.7.2
+pkgver=2.7.3
 pkgrel=0
 pkgdesc="Network UPS tools - server"
 url="http://www.networkupstools.org"
@@ -14,13 +14,11 @@ pkggroups="nut"
 install="$pkgname.pre-install"
 subpackages="$pkgname-doc $pkgname-dev"
 source="http://www.networkupstools.org/source/2.7/$pkgname-$pkgver.tar.gz
-	libm.patch
 	nut-upsd.initd
 	nut-upsd.confd
 	nut-upsmon.initd
-	nut-upsmon.confd"
-
-# bcmxcp.patch - sorry no bcmxc and no bcmxcp_usb (get errors about undefined reference to `ldexp')
+	nut-upsmon.confd
+	config-sub.patch"
 
 _builddir="$srcdir"/$pkgname-$pkgver
 
@@ -75,29 +73,23 @@ package() {
 	install -D -m0644 "$srcdir"/nut-upsd.confd "$pkgdir"/etc/conf.d/nut-upsd || return 1
 	install -D -m0755 "$srcdir"/nut-upsmon.initd "$pkgdir"/etc/init.d/nut-upsmon || return 1
 	install -D -m0644 "$srcdir"/nut-upsmon.confd "$pkgdir"/etc/conf.d/nut-upsmon || return 1
-	#install -d -o nut -g nut -m700 "$pkgdir"/var/lib/nut || return 1
-	#for file in "$pkgdir"/etc/nut/*.sample
-	#do
-	#	mv $file "$pkgdir"/etc/nut/`basename $file .sample`
-	#done
-
 }
 
-md5sums="c3568b42e058cfc385b46d25140dced4  nut-2.7.2.tar.gz
-f12613b6d043092c0c66c646702674d8  libm.patch
-e981e4ff27c0fc455ad2f319cbf29c36  nut-upsd.initd
+md5sums="a1a7f747093663e1f39ab595b63b45e4  nut-2.7.3.tar.gz
+2a5b693a967040270edc883e61f7ddef  nut-upsd.initd
 6b068c71884f8d66b5b7395b4a14d821  nut-upsd.confd
-21f6121acfeb17d51376bb0d11518804  nut-upsmon.initd
-6b068c71884f8d66b5b7395b4a14d821  nut-upsmon.confd"
-sha256sums="4d5365359b059d96dfcb77458f361a114d26c84f1297ffcd0c6c166f7200376d  nut-2.7.2.tar.gz
-bb12164d2cfe560fa505435d98681b80a22f0a6bf819dde83ad4e638c2abc111  libm.patch
-afb6878a67a6effc9199b24dbcc4be20a799abbd370d8ebcfe09d05bb1ba11d6  nut-upsd.initd
+30dc9b43f956d7a6545f71a0d1d8dc47  nut-upsmon.initd
+6b068c71884f8d66b5b7395b4a14d821  nut-upsmon.confd
+2073c7d345cc59f6dc4f4322f63ccfa0  config-sub.patch"
+sha256sums="ff44d95d06a51559a0a018eef7f8d17911c1002b6352a7d7580ff75acb12126b  nut-2.7.3.tar.gz
+2eff9796f0e8d0e82c8d4ac1220885db5e09b8b91f4f49ce590da028e210aa2a  nut-upsd.initd
 8ee7ff65c3ef84bb1bc0b458ff5b574bb8a6ac656a6d3a40441185b352481dda  nut-upsd.confd
-0dfbc87ff6bb6c66132ecf4d7d09710ba34343e7cf42733484fa2df77b9be4cb  nut-upsmon.initd
-8ee7ff65c3ef84bb1bc0b458ff5b574bb8a6ac656a6d3a40441185b352481dda  nut-upsmon.confd"
-sha512sums="7d6b44e8f2d03544d9825274f4f3039911e335eb51620ded3dc08d51aeb096281c2ec848831815c54eecd4f2a25bdb1e6e5f479422e5291f03c3055da7ba52e6  nut-2.7.2.tar.gz
-091e9529a1432e7a011c2ced8a7ca50568524823e3c1bb8d023f4501fe4c337e4b909e978aedc9cb2b68be6c690e3300f0d2a839c4765c39e7618d6767c2468a  libm.patch
-a0a205805a7cd7bc70163d9b50e51f16e74af22a799f74b1155430ca65090d64af972070d04759e4ac8e83e088bcbc531d9e9abd38482f74a885965ff0dc0ed8  nut-upsd.initd
+37924fe62b4c837579283f080990d2e4cbd84dd85fd5c3c0fd45f665152a7d86  nut-upsmon.initd
+8ee7ff65c3ef84bb1bc0b458ff5b574bb8a6ac656a6d3a40441185b352481dda  nut-upsmon.confd
+8e44edcbfa1f2f9344659ca08bfeb93dec3e8356257b882d07aa61107fdac4a0  config-sub.patch"
+sha512sums="3dd978712dc0fabe7e194dbf6d7bb442c456aa4d45bfc63ede8a3acae23c66811cbcf2705b55a6739129b5f120e6f5865bcb9d19eb9080507a85e2624d5663d6  nut-2.7.3.tar.gz
+94333e58fca66111318f04f00f225a2203716b3d0bbfa39593a71de16f740df8623fdffba2e7821b3ae92e96c2fb4a0ac3661f1da31409f3b13b8f704e9c07c9  nut-upsd.initd
 cf93ce44cb6fcf980f48f77abeeabb8d0b4008e8258cf7085d68b2a9c5c10c818dbf0030630218fcf8d9c9aba43c06bda28f91efca9cc783438ec0192f10eb5d  nut-upsd.confd
-aa6efe85e874ada8b4cea0581bca6b8c24fa336fe1b197925519041f55b21d77683c31e2d8304fb45062cb52a55d44682981fcd22c7db0d2f8adf7e866324efe  nut-upsmon.initd
-cf93ce44cb6fcf980f48f77abeeabb8d0b4008e8258cf7085d68b2a9c5c10c818dbf0030630218fcf8d9c9aba43c06bda28f91efca9cc783438ec0192f10eb5d  nut-upsmon.confd"
+31ac70d1ec5c2db7e7faf2db14ab03a012287e2b0cc3e42755e7886e444a11a701cf870d89d44d7a80f3034f9856a163269a9071dd25f2f98e416677c18b0791  nut-upsmon.initd
+cf93ce44cb6fcf980f48f77abeeabb8d0b4008e8258cf7085d68b2a9c5c10c818dbf0030630218fcf8d9c9aba43c06bda28f91efca9cc783438ec0192f10eb5d  nut-upsmon.confd
+9253bc4eb3ed48ef4978e4948a3febbc7fb40067b3bdf642b8fb362e7e791d3bd91da25a7941965a675eb5e5ed9ef8b434d1a50bb499722a9805d3a689077e52  config-sub.patch"
diff --git a/testing/nut/config-sub.patch b/testing/nut/config-sub.patch
new file mode 100644
index 0000000000000000000000000000000000000000..22bbbad541fce8ee772534da0ef736aeddf3f12b
--- /dev/null
+++ b/testing/nut/config-sub.patch
@@ -0,0 +1,313 @@
+diff --git a/config.sub b/config.sub
+index bba4efb..6205f84 100755
+--- a/config.sub
++++ b/config.sub
+@@ -1,18 +1,24 @@
+ #! /bin/sh
+ # Configuration validation subroutine script.
+-#   Copyright 1992-2014 Free Software Foundation, Inc.
++#   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
++#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
++#   2011, 2012 Free Software Foundation, Inc.
+ 
+-timestamp='2014-09-11'
++timestamp='2012-04-18'
+ 
+-# This file is free software; you can redistribute it and/or modify it
+-# under the terms of the GNU General Public License as published by
+-# the Free Software Foundation; either version 3 of the License, or
++# This file is (in principle) common to ALL GNU software.
++# The presence of a machine in this file suggests that SOME GNU software
++# can handle that machine.  It does not imply ALL GNU software can.
++#
++# This file is free software; you can redistribute it and/or modify
++# it under the terms of the GNU General Public License as published by
++# the Free Software Foundation; either version 2 of the License, or
+ # (at your option) any later version.
+ #
+-# This program is distributed in the hope that it will be useful, but
+-# WITHOUT ANY WARRANTY; without even the implied warranty of
+-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+-# General Public License for more details.
++# This program is distributed in the hope that it will be useful,
++# but WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++# GNU General Public License for more details.
+ #
+ # You should have received a copy of the GNU General Public License
+ # along with this program; if not, see <http://www.gnu.org/licenses/>.
+@@ -20,12 +26,11 @@ timestamp='2014-09-11'
+ # As a special exception to the GNU General Public License, if you
+ # distribute this file as part of a program that contains a
+ # configuration script generated by Autoconf, you may include it under
+-# the same distribution terms that you use for the rest of that
+-# program.  This Exception is an additional permission under section 7
+-# of the GNU General Public License, version 3 ("GPLv3").
++# the same distribution terms that you use for the rest of that program.
+ 
+ 
+-# Please send patches with a ChangeLog entry to config-patches@gnu.org.
++# Please send patches to <config-patches@gnu.org>.  Submit a context
++# diff and a properly formatted GNU ChangeLog entry.
+ #
+ # Configuration subroutine to validate and canonicalize a configuration type.
+ # Supply the specified configuration type as an argument.
+@@ -68,7 +73,9 @@ Report bugs and patches to <config-patches@gnu.org>."
+ version="\
+ GNU config.sub ($timestamp)
+ 
+-Copyright 1992-2014 Free Software Foundation, Inc.
++Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
++2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012
++Free Software Foundation, Inc.
+ 
+ This is free software; see the source for copying conditions.  There is NO
+ warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
+@@ -116,7 +123,7 @@ esac
+ maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
+ case $maybe_os in
+   nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
+-  linux-musl* | linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
++  linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
+   knetbsd*-gnu* | netbsd*-gnu* | \
+   kopensolaris*-gnu* | \
+   storm-chaos* | os2-emx* | rtmk-nova*)
+@@ -149,7 +156,7 @@ case $os in
+ 	-convergent* | -ncr* | -news | -32* | -3600* | -3100* | -hitachi* |\
+ 	-c[123]* | -convex* | -sun | -crds | -omron* | -dg | -ultra | -tti* | \
+ 	-harris | -dolphin | -highlevel | -gould | -cbm | -ns | -masscomp | \
+-	-apple | -axis | -knuth | -cray | -microblaze*)
++	-apple | -axis | -knuth | -cray | -microblaze)
+ 		os=
+ 		basic_machine=$1
+ 		;;
+@@ -252,12 +259,10 @@ case $basic_machine in
+ 	| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
+ 	| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
+ 	| am33_2.0 \
+-	| arc | arceb \
+-	| arm | arm[bl]e | arme[lb] | armv[2-8] | armv[3-8][lb] | armv7[arm] \
+-	| avr | avr32 \
+-	| be32 | be64 \
++	| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
++        | be32 | be64 \
+ 	| bfin \
+-	| c4x | c8051 | clipper \
++	| c4x | clipper \
+ 	| d10v | d30v | dlx | dsp16xx \
+ 	| epiphany \
+ 	| fido | fr30 | frv \
+@@ -265,11 +270,10 @@ case $basic_machine in
+ 	| hexagon \
+ 	| i370 | i860 | i960 | ia64 \
+ 	| ip2k | iq2000 \
+-	| k1om \
+ 	| le32 | le64 \
+ 	| lm32 \
+ 	| m32c | m32r | m32rle | m68000 | m68k | m88k \
+-	| maxq | mb | microblaze | microblazeel | mcore | mep | metag \
++	| maxq | mb | microblaze | mcore | mep | metag \
+ 	| mips | mipsbe | mipseb | mipsel | mipsle \
+ 	| mips16 \
+ 	| mips64 | mips64el \
+@@ -283,26 +287,23 @@ case $basic_machine in
+ 	| mips64vr5900 | mips64vr5900el \
+ 	| mipsisa32 | mipsisa32el \
+ 	| mipsisa32r2 | mipsisa32r2el \
+-	| mipsisa32r6 | mipsisa32r6el \
+ 	| mipsisa64 | mipsisa64el \
+ 	| mipsisa64r2 | mipsisa64r2el \
+-	| mipsisa64r6 | mipsisa64r6el \
+ 	| mipsisa64sb1 | mipsisa64sb1el \
+ 	| mipsisa64sr71k | mipsisa64sr71kel \
+-	| mipsr5900 | mipsr5900el \
+ 	| mipstx39 | mipstx39el \
+ 	| mn10200 | mn10300 \
+ 	| moxie \
+ 	| mt \
+ 	| msp430 \
+ 	| nds32 | nds32le | nds32be \
+-	| nios | nios2 | nios2eb | nios2el \
++	| nios | nios2 \
+ 	| ns16k | ns32k \
+-	| open8 | or1k | or1knd | or32 \
++	| open8 \
++	| or32 \
+ 	| pdp10 | pdp11 | pj | pjl \
+ 	| powerpc | powerpc64 | powerpc64le | powerpcle \
+ 	| pyramid \
+-	| riscv32 | riscv64 \
+ 	| rl78 | rx \
+ 	| score \
+ 	| sh | sh[1234] | sh[24]a | sh[24]aeb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
+@@ -327,7 +328,7 @@ case $basic_machine in
+ 	c6x)
+ 		basic_machine=tic6x-unknown
+ 		;;
+-	m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | nvptx | picochip)
++	m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | picochip)
+ 		basic_machine=$basic_machine-unknown
+ 		os=-none
+ 		;;
+@@ -369,13 +370,13 @@ case $basic_machine in
+ 	| aarch64-* | aarch64_be-* \
+ 	| alpha-* | alphaev[4-8]-* | alphaev56-* | alphaev6[78]-* \
+ 	| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
+-	| alphapca5[67]-* | alpha64pca5[67]-* | arc-* | arceb-* \
++	| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
+ 	| arm-*  | armbe-* | armle-* | armeb-* | armv*-* \
+ 	| avr-* | avr32-* \
+ 	| be32-* | be64-* \
+ 	| bfin-* | bs2000-* \
+ 	| c[123]* | c30-* | [cjt]90-* | c4x-* \
+-	| c8051-* | clipper-* | craynv-* | cydra-* \
++	| clipper-* | craynv-* | cydra-* \
+ 	| d10v-* | d30v-* | dlx-* \
+ 	| elxsi-* \
+ 	| f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
+@@ -384,13 +385,11 @@ case $basic_machine in
+ 	| hexagon-* \
+ 	| i*86-* | i860-* | i960-* | ia64-* \
+ 	| ip2k-* | iq2000-* \
+-	| k1om-* \
+ 	| le32-* | le64-* \
+ 	| lm32-* \
+ 	| m32c-* | m32r-* | m32rle-* \
+ 	| m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
+-	| m88110-* | m88k-* | maxq-* | mcore-* | metag-* \
+-	| microblaze-* | microblazeel-* \
++	| m88110-* | m88k-* | maxq-* | mcore-* | metag-* | microblaze-* \
+ 	| mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
+ 	| mips16-* \
+ 	| mips64-* | mips64el-* \
+@@ -404,22 +403,18 @@ case $basic_machine in
+ 	| mips64vr5900-* | mips64vr5900el-* \
+ 	| mipsisa32-* | mipsisa32el-* \
+ 	| mipsisa32r2-* | mipsisa32r2el-* \
+-	| mipsisa32r6-* | mipsisa32r6el-* \
+ 	| mipsisa64-* | mipsisa64el-* \
+ 	| mipsisa64r2-* | mipsisa64r2el-* \
+-	| mipsisa64r6-* | mipsisa64r6el-* \
+ 	| mipsisa64sb1-* | mipsisa64sb1el-* \
+ 	| mipsisa64sr71k-* | mipsisa64sr71kel-* \
+-	| mipsr5900-* | mipsr5900el-* \
+ 	| mipstx39-* | mipstx39el-* \
+ 	| mmix-* \
+ 	| mt-* \
+ 	| msp430-* \
+ 	| nds32-* | nds32le-* | nds32be-* \
+-	| nios-* | nios2-* | nios2eb-* | nios2el-* \
++	| nios-* | nios2-* \
+ 	| none-* | np1-* | ns16k-* | ns32k-* \
+ 	| open8-* \
+-	| or1k*-* \
+ 	| orion-* \
+ 	| pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
+ 	| powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* \
+@@ -793,15 +788,11 @@ case $basic_machine in
+ 		basic_machine=ns32k-utek
+ 		os=-sysv
+ 		;;
+-	microblaze*)
++	microblaze)
+ 		basic_machine=microblaze-xilinx
+ 		;;
+-	mingw64)
+-		basic_machine=x86_64-pc
+-		os=-mingw64
+-		;;
+ 	mingw32)
+-		basic_machine=i686-pc
++		basic_machine=i386-pc
+ 		os=-mingw32
+ 		;;
+ 	mingw32ce)
+@@ -829,10 +820,6 @@ case $basic_machine in
+ 		basic_machine=powerpc-unknown
+ 		os=-morphos
+ 		;;
+-	moxiebox)
+-		basic_machine=moxie-unknown
+-		os=-moxiebox
+-		;;
+ 	msdos)
+ 		basic_machine=i386-pc
+ 		os=-msdos
+@@ -841,7 +828,7 @@ case $basic_machine in
+ 		basic_machine=`echo $basic_machine | sed -e 's/ms1-/mt-/'`
+ 		;;
+ 	msys)
+-		basic_machine=i686-pc
++		basic_machine=i386-pc
+ 		os=-msys
+ 		;;
+ 	mvs)
+@@ -1032,11 +1019,7 @@ case $basic_machine in
+ 		basic_machine=i586-unknown
+ 		os=-pw32
+ 		;;
+-	rdos | rdos64)
+-		basic_machine=x86_64-pc
+-		os=-rdos
+-		;;
+-	rdos32)
++	rdos)
+ 		basic_machine=i386-pc
+ 		os=-rdos
+ 		;;
+@@ -1363,29 +1346,29 @@ case $os in
+ 	-gnu* | -bsd* | -mach* | -minix* | -genix* | -ultrix* | -irix* \
+ 	      | -*vms* | -sco* | -esix* | -isc* | -aix* | -cnk* | -sunos | -sunos[34]*\
+ 	      | -hpux* | -unos* | -osf* | -luna* | -dgux* | -auroraux* | -solaris* \
+-	      | -sym* | -kopensolaris* | -plan9* \
++	      | -sym* | -kopensolaris* \
+ 	      | -amigaos* | -amigados* | -msdos* | -newsos* | -unicos* | -aof* \
+ 	      | -aos* | -aros* \
+ 	      | -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
+ 	      | -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
+ 	      | -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* \
+-	      | -bitrig* | -openbsd* | -solidbsd* \
++	      | -openbsd* | -solidbsd* \
+ 	      | -ekkobsd* | -kfreebsd* | -freebsd* | -riscix* | -lynxos* \
+ 	      | -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
+ 	      | -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
+ 	      | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
+ 	      | -chorusos* | -chorusrdb* | -cegcc* \
+ 	      | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
+-	      | -mingw32* | -mingw64* | -linux-gnu* | -linux-android* \
+-	      | -linux-newlib* | -linux-musl* | -linux-uclibc* \
+-	      | -uxpv* | -beos* | -mpeix* | -udk* | -moxiebox* \
++	      | -mingw32* | -linux-gnu* | -linux-android* \
++	      | -linux-newlib* | -linux-uclibc* \
++	      | -uxpv* | -beos* | -mpeix* | -udk* \
+ 	      | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
+ 	      | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
+ 	      | -storm-chaos* | -tops10* | -tenex* | -tops20* | -its* \
+ 	      | -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
+ 	      | -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
+ 	      | -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
+-	      | -skyos* | -haiku* | -rdos* | -toppers* | -drops* | -es* | -tirtos*)
++	      | -skyos* | -haiku* | -rdos* | -toppers* | -drops* | -es*)
+ 	# Remember, each alternative MUST END IN *, to match a version number.
+ 		;;
+ 	-qnx*)
+@@ -1509,6 +1492,9 @@ case $os in
+ 	-aros*)
+ 		os=-aros
+ 		;;
++	-kaos*)
++		os=-kaos
++		;;
+ 	-zvmoe)
+ 		os=-zvmoe
+ 		;;
+@@ -1557,9 +1543,6 @@ case $basic_machine in
+ 	c4x-* | tic4x-*)
+ 		os=-coff
+ 		;;
+-	c8051-*)
+-		os=-elf
+-		;;
+ 	hexagon-*)
+ 		os=-elf
+ 		;;
diff --git a/testing/nut/libm.patch b/testing/nut/libm.patch
deleted file mode 100644
index cab08ad9f25d3e8773c9ade2219a8b4ef209e9ce..0000000000000000000000000000000000000000
--- a/testing/nut/libm.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./drivers/Makefile.am.orig
-+++ ./drivers/Makefile.am
-@@ -180,7 +180,7 @@
- tripplite_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
- 
- bcmxcp_usb_SOURCES = bcmxcp_usb.c bcmxcp.c usb-common.c
--bcmxcp_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS)
-+bcmxcp_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
- 
- blazer_usb_SOURCES = blazer.c blazer_usb.c libusb.c usb-common.c
- blazer_usb_LDADD = $(LDADD_DRIVERS) $(LIBUSB_LIBS) -lm
diff --git a/testing/nut/nut-upsd.initd b/testing/nut/nut-upsd.initd
index dcc3b595be528ba3e28a06d64d0f49cdf0f22139..db1e4b1f70c6778e6d3fe624d9b84f5991e05b9d 100644
--- a/testing/nut/nut-upsd.initd
+++ b/testing/nut/nut-upsd.initd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
 
 extra_started_commands="reload"
 
diff --git a/testing/nut/nut-upsmon.initd b/testing/nut/nut-upsmon.initd
index 53f1b1bacf839277361ce7db7974da6b47a2b2e7..3c98c17d03fbbb507c65bc2792596312543b977c 100644
--- a/testing/nut/nut-upsmon.initd
+++ b/testing/nut/nut-upsmon.initd
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
 
 extra_started_commands="reload"