diff --git a/main/audacity/APKBUILD b/main/audacity/APKBUILD
index 6137501f621bef5101f48de27ff76099b6eeb6fd..13e8adc86ef9c2e36fb677efdf5a2b82e6656c20 100644
--- a/main/audacity/APKBUILD
+++ b/main/audacity/APKBUILD
@@ -1,26 +1,42 @@
 # Contributor: Natanael Copa <ncopa@alpinelinux.org>
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=audacity
-pkgver=2.0.6
-pkgrel=1
+pkgver=2.1.0
+pkgrel=0
 pkgdesc="Multitrack audio editor"
 url="http://audacity.sourceforge.net"
 arch="all"
 license="GPL2"
 depends=""
 depends_dev=""
-makedepends="$depends_dev wxgtk2.8-dev alsa-lib-dev libsndfile-dev flac-dev
-	libogg-dev libvorbis-dev libsamplerate-dev expat-dev libmad-dev
-	libid3tag-dev taglib-dev bash"
+makedepends="$depends_dev
+	alsa-lib-dev
+	bash
+	expat-dev
+	flac-dev
+	jack-dev
+	lame-dev
+	libid3tag-dev
+	libmad-dev
+	libogg-dev
+	libsndfile-dev
+	libvorbis-dev
+	portaudio-dev
+	soxr-dev
+	taglib-dev
+	wxgtk2.8-dev
+	"
+
 install=""
 subpackages="$pkgname-doc $pkgname-lang"
-source="http://sourceforge.net/projects/audacity/files/audacity-minsrc-$pkgver.tar.xz"
+source="http://sourceforge.net/projects/audacity/files/audacity-minsrc-$pkgver.tar.xz
+	musl-workaround.patch
+	"
 
-_builddir="$srcdir"/audacity-src-$pkgver
+_builddir="$srcdir"/audacity-minsrc-$pkgver
 prepare() {
 	local i
 	cd "$_builddir"
-	update_config_sub || return 1
 	for i in $source; do
 		case $i in
 		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -44,9 +60,17 @@ build() {
 		--prefix=/usr \
 		--sysconfdir=/etc \
 		--mandir=/usr/share/man \
+		--with-lib-preference=system \
 		--with-libsndfile=system \
-		--with-libsamplerate=system \
+		--with-soxr=system \
+		--with-id3tag=system \
+		--with-libvorbis=system \
+		--with-portaudio=system \
+		--with-libmad=system \
+		--with-widgetextra=local \
 		--without-libresample \
+		--without-libsamplerate \
+		--without-ffmpeg \
 		$_arch \
 		|| return 1
 	make || return 1
@@ -58,6 +82,9 @@ package() {
 	rm -f "$pkgdir"/usr/lib/*.la
 }
 
-md5sums="fb7b39a1ec8cb562be5ee65725af8832  audacity-minsrc-2.0.6.tar.xz"
-sha256sums="3080c190e678e0d682961a36c6e990c572dacd6b5ce499e5cec7362e9fa37d7b  audacity-minsrc-2.0.6.tar.xz"
-sha512sums="e61e406790e81ebbea08019585d3d1000c14f001bba7b5a55bebf89931ea246f9f5b52315f217e10bc03cab4805d7fb4efda5acefc5e4d11764206244b61683a  audacity-minsrc-2.0.6.tar.xz"
+md5sums="d21a794cc1e2a1567d3d75b53b1f2f02  audacity-minsrc-2.1.0.tar.xz
+f4d0e4b195c2f604cea8e8d696ffcc17  musl-workaround.patch"
+sha256sums="b0d98d89b38be233e88af81e1add649732484b6f8feec95dc5977accdde042b3  audacity-minsrc-2.1.0.tar.xz
+888e2a0c0055f11300ecaa550aff5ab1991dbce3b2dab0d05596c3b304b2c675  musl-workaround.patch"
+sha512sums="5ed441b567bc72a794d9d5a1248db137d1a6d019b5fcdcb8b536a509ecacbf5d85b50c2a0cad484f84053dff4ffa662027cca157fde4b18f9d53b2bd106c34b4  audacity-minsrc-2.1.0.tar.xz
+b5488a7f5398c07fe986e090b8d61353ecba594ed23fda6a4444e59718f7d1e8bd5c716047ce139350983d5609b5810362a78a2fd5d85e9b1730d196c57c685b  musl-workaround.patch"
diff --git a/main/audacity/musl-workaround.patch b/main/audacity/musl-workaround.patch
new file mode 100644
index 0000000000000000000000000000000000000000..ababf9036671d76f5708fec5249a8c8b168c5a8b
--- /dev/null
+++ b/main/audacity/musl-workaround.patch
@@ -0,0 +1,16 @@
+The use of RTLD_DEEPBIND is just a workaround and not a real fix.
+And we cannot use it...
+
+--- ./src/effects/VST/VSTEffect.cpp.orig
++++ ./src/effects/VST/VSTEffect.cpp
+@@ -2609,6 +2609,10 @@
+    // symbols.
+    //
+    // Once we define a proper external API, the flags can be removed.
++// GNU extension
++#ifndef RTLD_DEEPBIND
++#define RTLD_DEEPBIND 0
++#endif
+    void *lib = dlopen((const char *)wxString(realPath).ToUTF8(), RTLD_NOW | RTLD_LOCAL | RTLD_DEEPBIND);
+    if (!lib) 
+    {