Commit 186e1a80 authored by Kevin Daudt's avatar Kevin Daudt 💻
Browse files

community/py3-flake8: fix test due to deprecation warning

Using LegacyVersion results in a warning, which causes the test suite to
fail. Add this warning to the list of ignored warnings.
parent d8dee939
......@@ -10,7 +10,9 @@ arch="noarch"
license="MIT"
depends="py3-entrypoints py3-pyflakes py3-pycodestyle py3-mccabe py3-setuptools"
checkdepends="py3-pytest py3-pbr py3-atomicwrites py3-attrs py3-pluggy py3-six py3-mock"
source="https://files.pythonhosted.org/packages/source/f/flake8/flake8-$pkgver.tar.gz"
source="https://files.pythonhosted.org/packages/source/f/flake8/flake8-$pkgver.tar.gz
tests-ignore-deprecated-legacy-version.patch
"
builddir="$srcdir/flake8-$pkgver"
replaces="py-flake8" # Backwards compatibility
......@@ -35,4 +37,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="51ed09beed50175573e6184b404431b3f89aa6594c40c70ed8288982fe12c2a68992e36d69c99013188f03555bf9fef1ba4f111f8e389cef1e1daa69b41ff5b0 flake8-3.8.4.tar.gz"
sha512sums="51ed09beed50175573e6184b404431b3f89aa6594c40c70ed8288982fe12c2a68992e36d69c99013188f03555bf9fef1ba4f111f8e389cef1e1daa69b41ff5b0 flake8-3.8.4.tar.gz
d2903dc3d1020839f0546ad598745f598a79131f78a8081a19665190d78703d88e2657b4cdb82f7781adfb68f38ba890d18f1b49b30091331ae9b5d3aa9bb609 tests-ignore-deprecated-legacy-version.patch"
diff --git a/pytest.ini b/pytest.ini
index 4a00d9a..38e1959 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -8,3 +8,4 @@ filterwarnings =
# python3 raises this when importing setuptools
ignore:the imp module is deprecated in favour of importlib.*:PendingDeprecationWarning
ignore:the imp module is deprecated in favour of importlib.*:DeprecationWarning
+ ignore:Creating a LegacyVersion has been deprecated and will be removed in the next major release:DeprecationWarning
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment